Bug 1106145 - dmlite-plugins-memcache: FTBFS in rawhide
Summary: dmlite-plugins-memcache: FTBFS in rawhide
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: dmlite-plugins-memcache
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrien Devresse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1108325
Blocks: F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 03:17 UTC by Dennis Gilmore
Modified: 2015-07-06 07:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-06 07:00:26 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.92 KB, text/plain)
2014-06-09 03:17 UTC, Dennis Gilmore
no flags Details
root.log (86.76 KB, text/plain)
2014-06-09 03:17 UTC, Dennis Gilmore
no flags Details
state.log (1.13 KB, text/plain)
2014-06-09 03:17 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2014-06-09 03:17:03 UTC
Your package dmlite-plugins-memcache failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6951772

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 03:17:06 UTC
Created attachment 904012 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 03:17:08 UTC
Created attachment 904013 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 03:17:10 UTC
Created attachment 904014 [details]
state.log

Comment 4 Adrien Devresse 2014-06-10 13:09:46 UTC
Hi,


libmemcached since 1.0.18 enforce the usage of C++11, meaning that all softwares that compiled against libmemcached need to enforced C++11 too.

And it's naturally not the case of dmlite-plugins-memcache.

Comment 5 Adrien Devresse 2014-06-11 17:00:30 UTC
Bug related to libmemcached, not to dmlite-plugins-memcache

libmemcached forces the usage of c++11 unintentionally with GCC 4.9

This issue comes from the line "# include <cinttypes>" inside memcached.h which should not be exposed.

Comment 6 Adrien Devresse 2014-06-11 17:21:48 UTC
bug reported upstream: https://bugs.launchpad.net/libmemcached/+bug/1328985

Comment 7 Alejandro Alvarez 2014-06-16 06:45:58 UTC
Hi Adrien,

What if we give C++11 a try in Rawhide? We will have to do the switch eventually...

Comment 8 Adrien Devresse 2014-06-16 07:18:59 UTC
Hi Alejandro,

We discuss of this with the upstream last week (Fab), it seems that it's not on schedule for now to enable C++11 for the full dmlite stack.

Adrien

Comment 9 Alejandro Alvarez 2015-02-24 08:10:54 UTC
Maybe report to the rpm maintainer, and get it fixed there?

Comment 10 Jaroslav Reznik 2015-03-03 17:02:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 11 Alejandro Alvarez 2015-07-06 07:00:26 UTC
dmlite-plugins-memcache is now deprecated, as it is built as part of dmlite


Note You need to log in before you can comment on or make changes to this bug.