Bug 110615 - not able to change the greeter from gdm to kdm, variable in prefdm does not match the variable in /etc/sysconfig/desktop.
not able to change the greeter from gdm to kdm, variable in prefdm does not m...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-21 14:00 EST by Wayne Leutwyler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-24 14:31:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Leutwyler 2003-11-21 14:00:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
prefdm calls the $DISPLAYMANAGER from the /etc/sysconfig/desktop

Part of the prefdm:

preferred=
if [ -f /etc/sysconfig/desktop ]; then
        . /etc/sysconfig/desktop
        if [ "$DISPLAYMANAGER" = GNOME ]; then
                preferred=gdm
        elif [ "$DISPLAYMANAGER" = KDE ]; then
                preferred=kdm
        elif [ "$DISPLAYMANAGER" = XDM ]; then
                preferred=xdm
        fi
fi

but the /etc/sysconfig/desktop looks like this:

DESKTOP="KDE"

There is no DISPLAYMANAGER variable in the /etc/sysconfig/desktop file.

I changed DESKTOP to DISPLAYMANAGER and was able to change the greeter
from GNOME to KDE.

Version-Release number of selected component (if applicable):
xinitrc-3.35-1

How reproducible:
Always

Steps to Reproduce:
1. Want to use the KDE greeter and not the GNOME Greeter
2. Change the /etc/sysconfig/desktop to DESKTOP="KDE"
3. Reboot system.
4. The GNOME Greeter is still active.    

Additional info:
Comment 1 Mike A. Harris 2003-11-24 14:31:36 EST
There are two separate variables, "DESKTOP" which chooses wether
you are using GNOME or KDE or whatever, and DISPLAYMANAGER, which
is optional, and determines wether you want to use xdm/gdm/kdm.

Both variables have existed in Red Hat OS products pretty much
forever, and work as they always have.  The variables work as they
are intended to work, so you probably have a misunderstanding.
Please read the documentation if you have any confusion over how
these variables work or how they should be used properly.

This is not a bug.

Closing NOTABUG.
Comment 2 mark 2003-12-04 09:24:28 EST
I experienced exactly the same issue and "resolved" it exactly the
same way as Wayne did.
The explanation in comment #1 does not sound sufficient to me.

RH 9.0 referece guide says:

In runlevel 5, the /etc/inittab runs a script called /etc/X11/prefdm.
The prefdm script executes the preferred X display manager ó gdm, kdm,
or xdm, depending on the contents of the /etc/sysconfig/desktop

So if the /etc/sysconfig/desktop file sets the variable DESKTOP
while the /etc/X11/prefdm checks the variable DISPLAYMANAGER, how can
one depend on other? Something is wrong here.

Where then the variable DISPLAYMANAGER is set? 
Comment 3 Mike A. Harris 2003-12-04 13:30:59 EST
As stated above, this is very much not a bug.  The two variables
serve totally different purposes, and both of you misunderstand
them.  I strongly suggest reading the installation manual and OS
reference guides to learn how both of these variables are used,
and if you continue to have problems, for you to seek technical
support via one of the Red Hat mailing lists.  These variables have
worked the exact same way for the last 3-4 years, and do _exactly_
what they were designed to do, and they do work properly as intended.

Bugzilla is _NOT_ a technical support forum, and this is entirely
a technical support issue.

Note You need to log in before you can comment on or make changes to this bug.