Bug 110623 - Installation crash on Compaq 2500 when using mem=xxxM
Installation crash on Compaq 2500 when using mem=xxxM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-21 14:49 EST by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 16:32:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-21 14:49:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Installation crashes during installation of RHES 3.0 on Compaq 2500 
when passing the mem=xxxM (e.g. boot: linux mem=351M noprobe )

This results in a kernel panic where the kernel can't find the VFS: 
Cannot open root device "" or 48:03 

The mem=  statement is needed on this machine because the kernel only 
sees 16M instead of the 352M installed, and RHES wont install on 16 
megs unlike RHES 2.1 did and let me fix it later in the grub.conf 
file. Error messgage when kernel panics complains about appending the 
correct root "" 


Version-Release number of selected component (if applicable):
RHES 3.0

How reproducible:
Always

Steps to Reproduce:
1. boot cdrom or floopy disk with mem=xxxM ( with or without noprobe, 
expert, ramdisk_size=xxxx)
2. 
3.
    

Actual Results:  Kernel panics complaining about not being able to 
find 
VFS: Cannot open root device "" or 48:03 
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 48:03

Additional info:

System is Compaq 2500 w/ (2) overdrive 333mhz cpu's with 352megs ram. 
System has a Compaq Smart 2/P Array Controller.
Comment 1 Need Real Name 2003-11-24 19:02:59 EST
have finally solved issue by creating fresh boot disk and editing 
syslinux.cfg, which I have done may times before but the syntax was 
very picky 

created a label

label custom
kernel vmlinuz
append " initrd=initrd.img mem=exactmap mem=640K@0 mem=351M@1M"

notice the extra space after the quote in the append line
also the mem= statements would NOT work when using the hex 
equivalent "mem=exactmap mem=0x9f000@0 mem=0x15f00000@0x100000"

Comment 3 Jeffrey Moyer 2003-11-26 14:09:19 EST
Compaq 2500 is not descriptive.  Please include the full model, such
as, "Compaq ProLiant 2500."  One other question, did you try booting
w/ unmodified boot media using the command line parameters you list as
working?  e.g.

boot: linux mem=exactmap ...
Comment 4 Suzanne Hillman 2004-02-17 16:32:33 EST
As it's been almost three months since more information was requested,
I'm closing this. If there is still a problem, please reopen with
additional information.

Note You need to log in before you can comment on or make changes to this bug.