Bug 1106302 - freetalk: FTBFS in rawhide
Summary: freetalk: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: freetalk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 914012 992294 (view as bug list)
Depends On:
Blocks: F19FTBFS F20FTBFS F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 04:36 UTC by Dennis Gilmore
Modified: 2014-07-03 15:44 UTC (History)
3 users (show)

Fixed In Version: freetalk-4.0-0.1.rc4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-03 15:44:09 UTC


Attachments (Terms of Use)
build.log (7.72 KB, text/plain)
2014-06-09 04:36 UTC, Dennis Gilmore
no flags Details
root.log (83.15 KB, text/plain)
2014-06-09 04:36 UTC, Dennis Gilmore
no flags Details
state.log (1.06 KB, text/plain)
2014-06-09 04:36 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2014-06-09 04:36:32 UTC
Your package freetalk failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6965306

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 04:36:34 UTC
Created attachment 904465 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 04:36:36 UTC
Created attachment 904466 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 04:36:37 UTC
Created attachment 904467 [details]
state.log

Comment 4 Alphonse Steiner 2014-06-26 19:18:19 UTC
The build is failing since guile 2.0. It is easy to fix:
Add the patch: freetalk-3.2-compat-guile18.patch 
===============================================================================
--- configure.ac.orig   2014-06-26 21:04:52.941891816 +0200
+++ configure.ac        2014-06-26 21:05:47.005888500 +0200
@@ -16,7 +16,7 @@
 
 AC_SEARCH_LIBS([tgetent],[ncurses termcap curses])
 AC_CHECK_LIB([readline], [readline],,AC_MSG_ERROR([ERROR! readline not found...]))
-GUILE_FLAGS
+GUILE1_8_FLAGS
 AC_CHECK_LIB([guile],[scm_boot_guile],,AC_MSG_ERROR([ERROR! Guile 1.6 or above required.]))
 
 AC_CHECK_PROG([PKGCONFIG], [pkg-config], [yes], [no])
===============================================================================
And update the spec file:
===============================================================================
--- freetalk.spec.orig    2014-06-26 20:29:56.147020405 +0200
+++ freetalk.spec 2014-06-26 21:03:56.206895295 +0200
@@ -8,6 +8,7 @@
 Source0:       http://sv.gnu.org/download/freetalk/%{name}-%{version}.tar.gz
 
 Patch0:                %{name}-%{version}-glibc210.patch
+Patch1:     freetalk-3.2-compat-guile18.patch
 
 BuildRoot:     %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 
@@ -16,9 +17,10 @@
 Requires(preun): info
 
 BuildRequires: gettext
-BuildRequires: guile-devel
+BuildRequires: compat-guile18-devel
 BuildRequires: loudmouth-devel
 BuildRequires: readline-devel
+BuildRequires:  autoconf, automake
 
 %description
 GNU Freetalk is a console based Jabber client. It features a readline interface
@@ -28,8 +30,10 @@
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
 
 %build
+./autogen.sh
 %configure --disable-rpath
 make %{?_smp_mflags}
===============================================================================

Comment 5 Fedora Admin XMLRPC Client 2014-07-02 08:45:09 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Christopher Meng 2014-07-03 13:42:26 UTC
*** Bug 914012 has been marked as a duplicate of this bug. ***

Comment 7 Christopher Meng 2014-07-03 13:42:28 UTC
*** Bug 992294 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.