Bug 1106400 - [whql][netkvm]NDISTest 6.5 - [2 Machine] - OffloadLSO failed
Summary: [whql][netkvm]NDISTest 6.5 - [2 Machine] - OffloadLSO failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-09 09:16 UTC by lijin
Modified: 2015-11-24 08:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:41:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description lijin 2014-06-09 09:16:23 UTC
Description of problem:
"NDISTest 6.5 - [2 Machine] - OffloadLSO" job faild on win2012 and win2012R2 guest,not sure if this issue is due to RSC(maybe duplicate of bug950611),open a new one to track it.

Version-Release number of selected component (if applicable):
kernel-3.10.0-126.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7ev_0.2.x86_64
seabios-1.7.2.2-12.el7.x86_64
virtio-win-prewhql-86

How reproducible:
100%

Steps to Reproduce:
1.boot two guest with:
nic1:
/usr/libexec/qemu-kvm -name 086NIC201264CF2 -enable-kvm -m 6G -smp 8 -uuid 26a92f2f-6175-4618-9188-4956df472ba5 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/086NIC201264CF2,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=086NIC201264CF2,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=086NIC201264CF2.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:4b:2b:95:87,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:42:0e:a5:7b,bus=pci.0,mq=on -monitor stdi

nic2:
/usr/libexec/qemu-kvm -name 086NIC201264SVM -enable-kvm -m 6G -smp 8 -uuid d54df0cf-de94-4016-a08b-19770d34b75c -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/086NIC201264SVM,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=086NIC201264SVM,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=086NIC201264SVM.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:32:66:b0:24,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:24:1c:c9:2b,bus=pci.0,mq=on -monitor stdio

2.submit job in hck2.1

Actual results:
job failed

Expected results:
job can pass

Additional info:

Comment 3 lijin 2014-06-12 02:58:51 UTC
win8,win8.1,win2012,win2012R2 all hit this issue

Comment 5 Yossi Hindin 2015-01-15 10:06:30 UTC
Please, test this bug usinh build virtio-win-prewhql-0.1-100

Comment 7 lijin 2015-02-03 07:36:45 UTC
test with virtio-win-prewhql-100,all guests passed the job "NDISTest 6.5 - [2 Machine] - OffloadLSO",no bsod,no error

package info:
    virtio-win-prewhql-0.1-100
    qemu-kvm-rhev-2.1.2-20.el7.x86_64
    kernel-3.10.0-223.el7.x86_64
    seabios-1.7.5-7.el7.x86_64
    spice-server-0.12.4-9.el7.x86_64

Comment 9 lijin 2015-07-17 07:52:51 UTC
change status to verified according to comment#7

Comment 11 errata-xmlrpc 2015-11-24 08:41:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.