Bug 1106411 - 404 on /assets/AIX.png in Hosts -> Operating Systems
Summary: 404 on /assets/AIX.png in Hosts -> Operating Systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-09 09:38 UTC by Jan Hutař
Modified: 2019-09-26 13:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:41:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 2445 None None None 2016-04-22 16:21:13 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jan Hutař 2014-06-09 09:38:57 UTC
Description of problem:
When you have operating system with OS Family: AIX, it misses icon.


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140605.0


How reproducible:
always


Steps to Reproduce:
1. Hosts -> Operating Systems -> New Operating System
     among others set OS Family: AIX and submit


Actual results:
Icon next to description is missing, just "alt" text is being displayed. When you click at it, it changes to Firefox's broken image default icon.


Expected results:
Icon should be visible of should not be present at all.


Additional info:
Served asset /AIX.png - 404 Not Found (9ms)

ActionController::RoutingError (No route matches [GET] "/assets/AIX.png"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'

Comment 1 RHEL Program Management 2014-06-09 09:53:46 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2016-02-02 11:04:48 UTC
Upstream bug component is WebUI

Comment 4 Bryan Kearney 2016-02-10 23:04:28 UTC
Upstream bug assigned to bkearney@redhat.com

Comment 5 Bryan Kearney 2016-02-11 11:04:27 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/2445 has been closed
-------------
Dominic Cleal
From Ruediger's investigation, it appears we can't distribute this image:
https://github.com/theforeman/foreman/pull/999#issuecomment-31214407

Setting to need info until there's either a more royalty-free image, or a suitable licence for redistribution, sorry.
-------------
Lukas Zapletal
Oh and the link is: https://github.com/lzap/foreman-dummy-icons
-------------
Anonymous
Applied in changeset commit:f6014fbc44632ee0841ebc79f735428d0a9774fd.

Comment 7 Justin Sherrill 2016-03-24 19:06:08 UTC
Icon shows up properly

Comment 10 errata-xmlrpc 2016-07-27 08:41:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.