Bug 1106451 - CLI connect to EAP server with deployed infinispan application fails
Summary: CLI connect to EAP server with deployed infinispan application fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR1
: 6.3.0
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks: 1104639
TreeView+ depends on / blocked
 
Reported: 2014-06-09 11:45 UTC by Vitalii Chepeliuk
Modified: 2015-01-26 14:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-26 14:05:29 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
carmart-tx.war for testing CLI in library mode (8.02 MB, application/octet-stream)
2014-06-09 11:45 UTC, Vitalii Chepeliuk
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-4442 0 Major Resolved Package remoting jars for the embedded cli client 2015-10-08 13:56:17 UTC

Description Vitalii Chepeliuk 2014-06-09 11:45:00 UTC
Created attachment 904617 [details]
carmart-tx.war for testing CLI in library mode

Description of problem:


Version-Release number of selected component (if applicable):6.3.0.ER6


How reproducible:


Steps to Reproduce:
1. Run EAP server
2. Deploy attached application
3. Try to connect with server with bin/cli.sh and put commands
connect remoting://localhost:9999/DefaultCacheManager/carcache
put key1 key1
put key2 100
put key3 4139l
put key4 true
put key5 {"org.jboss.as.quickstarts.datagrid.carmart.model.Car":{"brand":"UKRAINE_UAZ","displacement":0.0,"type":"HATCHBACK","color":"MODRA","numberPlate":"UA 2896","country":"CZECH_REPUBLIC"}}
disconnect
~
Actual results:
No such container: DefaultCacheManager!
There are only 2 containers shown
[standalone@localhost:9999 cache-container=hibernate] container
hibernate  web

Expected results:
DefaultCacheManager should be registered and shown as our custom cache container

Additional info:

Comment 2 Vitalii Chepeliuk 2014-06-11 08:39:54 UTC
Probably cli.sh instead connecting to ISPN-CLI-SERVER is connecting to EAP-CLI-SERVER

Comment 3 Tristan Tarrant 2014-06-25 14:19:00 UTC
Vitalii this works for me.

Comment 4 Vitalii Chepeliuk 2014-06-25 18:32:17 UTC
(In reply to Tristan Tarrant from comment #3)
> Vitalii this works for me.

Ok then provide Tristan me please how you build and run script to connect from cli/cli-client module, Maybe we should bundle JDG with library version of CLI client for connecting to ISPN server inside EAP/TOMCAT


Note You need to log in before you can comment on or make changes to this bug.