Bug 110657 - mysqld won't start after changing basedir
Summary: mysqld won't start after changing basedir
Status: CLOSED DUPLICATE of bug 76051
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-22 12:57 UTC by Andreas-Johann Ulvestad
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas-Johann Ulvestad 2003-11-22 12:57:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030610 Galeon/1.3.7

Description of problem:
I attempted to move /var/lib/mysql to /storage/mysql and change the
correct lines in /etc/my.cnf. First of all, I also had to change the
initscript itself - that should not be needed at all. Furthermore,
even after changing everything there, there STILL is something
hardcoded to look in /var/lib/mysql for the socket, since 'service
mysqld start' reports FAILED. The mysql server is however starting up
fine.

After symlinking /var/lib/mysql to /storage/mysql, everything starts
up fine.

Version-Release number of selected component (if applicable):
mysql-server-3.23.58-4

How reproducible:
Always

Steps to Reproduce:
1. Change my.cnf
2. Attempt to start mysql-server

Additional info:

Comment 1 Patrick Macdonald 2003-11-24 15:25:44 UTC

*** This bug has been marked as a duplicate of 76051 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.