Bug 11066 - FvwmTaskBar can cause fvwm2 to crash
FvwmTaskBar can cause fvwm2 to crash
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fvwm2 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
http://www.cs.man.ac.uk/~jtl/RH/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-26 22:41 EDT by jtl
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-26 22:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jtl 2000-04-26 22:41:09 EDT
If this rings a bell, it's because it has been around for a while and has
been reported before. I can't find it now though. I think it was fixed in
RH5.2 but reappeared in RH6.0.

Anyway, the problem is that the Popup invoked by the start button has a
bogus window id as it's context, so when you invoke a window operation from
the menu, it kills fvwm2. :-( I have made a patch (and a new rpm spec and
rpms) which fix this. You can get them from the above URL (item 3).

The same bug is present in the latest fvwm2-2.3 snapshot, so I'll report it
to the fvwm-workers.

While hacking, I also fixed the FvwmTaskBarMailBox option and the failure
of the start button to pop out again once pressed -- same patch.
Comment 1 Ngo Than 2000-08-04 20:34:18 EDT
aplly your patch to fvwm2 for RC1. Thanks

Note You need to log in before you can comment on or make changes to this bug.