Bug 110668 - fetchmail from FC1 won't work with krb5-libs from RH9
Summary: fetchmail from FC1 won't work with krb5-libs from RH9
Alias: None
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Brock Organ
Depends On:
TreeView+ depends on / blocked
Reported: 2003-11-22 17:07 UTC by Göran Uddeborg
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-02 17:55:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Göran Uddeborg 2003-11-22 17:07:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The fetchmail of FC1 will complain about relocation error when used
with krb5-libs from RH9 update.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install RH9 with the upgrade krb5-libs-1.2.7-14
2.Install fetchmail-6.2.0-7 from FC1 with whatever RPM says it requires.
3.Run: fetchmail -V

Actual Results:  uebn> fetchmail -V
fetchmail: relocation error: fetchmail: undefined symbol:

Expected Results:  uebn>> fetchmail -V
This is fetchmail release 6.2.0+IMAP-GSS+NTLM+SSL+INET6+NLS

Additional info:

I suppose fetchmail should have a "Requires: krb5-libs >= 1.3.1-6". 
(Or at least "krb5-libs > 1.2.7-14".)

Comment 1 Miloslav Trmač 2005-06-02 17:55:57 UTC
I'm sorry about the late reply.

Basically, "don't do that". rpm automatic dependencies only notice so much,
and determining the exact package version (which may depend on the
distribution you use) is not worth the effort.

If you need to import packages from different distributions, rebuild the
source RPM.  This should eliminate all similar issues.

Comment 2 Göran Uddeborg 2005-06-03 22:47:20 UTC
> rpm automatic dependencies only notice so much,
> and determining the exact package version ... is not worth the effort.

Of course.  But I thought that when I now had stumbled on this one, I could
report it so you could note it in the package.  To avoid that others were hit by
THAT particular issue.

It wouldn't have to be the exact minimum version.  It could be a conservative
approximation.  Like the version included in the same release.

It will never be perfect.  But why not do it as good as possible, when the
effort is minimal?

Note You need to log in before you can comment on or make changes to this bug.