Bug 110668 - fetchmail from FC1 won't work with krb5-libs from RH9
fetchmail from FC1 won't work with krb5-libs from RH9
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-22 12:07 EST by Göran Uddeborg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-02 13:55:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2003-11-22 12:07:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The fetchmail of FC1 will complain about relocation error when used
with krb5-libs from RH9 update.

Version-Release number of selected component (if applicable):
fetchmail-6.2.0-7
(krb5-libs-1.2.7-14)

How reproducible:
Always

Steps to Reproduce:
1.Install RH9 with the upgrade krb5-libs-1.2.7-14
2.Install fetchmail-6.2.0-7 from FC1 with whatever RPM says it requires.
3.Run: fetchmail -V


Actual Results:  uebn> fetchmail -V
fetchmail: relocation error: fetchmail: undefined symbol:
GSS_C_NT_HOSTBASED_SERVICE


Expected Results:  uebn>> fetchmail -V
This is fetchmail release 6.2.0+IMAP-GSS+NTLM+SSL+INET6+NLS
...

Additional info:

I suppose fetchmail should have a "Requires: krb5-libs >= 1.3.1-6". 
(Or at least "krb5-libs > 1.2.7-14".)
Comment 1 Miloslav Trmač 2005-06-02 13:55:57 EDT
I'm sorry about the late reply.

Basically, "don't do that". rpm automatic dependencies only notice so much,
and determining the exact package version (which may depend on the
distribution you use) is not worth the effort.

If you need to import packages from different distributions, rebuild the
source RPM.  This should eliminate all similar issues.
Comment 2 Göran Uddeborg 2005-06-03 18:47:20 EDT
> rpm automatic dependencies only notice so much,
> and determining the exact package version ... is not worth the effort.

Of course.  But I thought that when I now had stumbled on this one, I could
report it so you could note it in the package.  To avoid that others were hit by
THAT particular issue.

It wouldn't have to be the exact minimum version.  It could be a conservative
approximation.  Like the version included in the same release.

It will never be perfect.  But why not do it as good as possible, when the
effort is minimal?

Note You need to log in before you can comment on or make changes to this bug.