Bug 110669 - postgresql-libs from FC1 won't work with krb5-libs from RH9
postgresql-libs from FC1 won't work with krb5-libs from RH9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Jee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-22 12:13 EST by Göran Uddeborg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-25 17:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2003-11-22 12:13:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Running e.g. psql from postgresql-7.3.4-2 will complain about
relocation error in libpq.so.3 when used with krb5-libs from RH9 update.

Version-Release number of selected component (if applicable):
postgresql-libs-7.3.4-2 (krb5-libs-1.2.7-14)

How reproducible:
Always

Steps to Reproduce:
1.Install RH9 with the upgrade krb5-libs-1.2.7-14
2.Install postgresql-7.3.4-2 and postgresql-libs-7.3.4-2 from FC1
3.Run psql
    

Actual Results:  uebn>> psql
psql: relocation error: /usr/lib/libpq.so.3: undefined symbol:
krb5_cc_get_principal


Expected Results:  Command prompt from psql.

Additional info:

I suppose postgresql-libs-7.3.4-2 should have a "Requires: krb5-libs
>= 1.3.1-6".  (Or at least "krb5-libs > 1.2.7-14".)
Comment 1 David Jee 2003-11-24 12:42:00 EST
I'm wondering why you're using binaries that are compiled for FC1 on a
RHL9 machine.  The FC1 binaries are compiled specifically against
FC1's library set, and they are not expected to work on any other
platform besides FC1.

We recently released postgresql-7.3.4-3.rhl9 RPMs as updates for RHL9,
and you can retrieve them by running up2date.  For RHL9 machines,
please use these RPMs instead of the FC1 RPMs.

Having said that, I think your suggestion about adding "Requires:
krb5-libs >= 1.3.1-6" in the FC1 RPM is a valid point.  It will be
included in the next update for FC1.
Comment 2 Göran Uddeborg 2003-11-24 14:28:54 EST
To answer your wondering:

The system isn't a pure RH9 system.  I'm upgrading, but don't want to
break everything at once, so I take it piecemal.  Whenever I need to
upgrade something, I take it from the most recent release.  It is then
of course reasonable for the new package to require the upgrade of
other packages too to work properly.  But if it does, it should say so
in its requirements.

Not that I expect everything to be perfect; I'm aware it is not easy
to know all such details.  But when I find it doesn't work I've
considered it a bug and reported it.  Like here! :-)
Comment 3 David Jee 2003-11-24 14:34:23 EST
Ah, I understand your situation now.  Thank you for clearing that up.
 And of course, you were perfectly right to have reported the bug. :)
 It is much appreciated.
Comment 4 David Jee 2003-11-25 17:47:41 EST
This is now fixed in the Fedora Core 1 update postgresql-7.3.4-11.

Note You need to log in before you can comment on or make changes to this bug.