Bug 110674 - Couldn't display "smb:///", because Nautilus cannot contact the SMB master browser.Check that an SMB server is running in the local network.
Couldn't display "smb:///", because Nautilus cannot contact the SMB master br...
Status: CLOSED DUPLICATE of bug 168908
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Depends On:
  Show dependency treegraph
Reported: 2003-11-22 19:48 EST by Brent Rowse
Modified: 2014-08-31 19:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-03 05:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Samba Configuration File (11.28 KB, text/plain)
2004-02-10 19:39 EST, Chris Mathey
no flags Details

  None (edit)
Description Brent Rowse 2003-11-22 19:48:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
When I try to browse the network to access XP machines, I get the message:

Couldn't display "smb:///", because Nautilus cannot contact the SMB
master browser.
Check that an SMB server is running in the local network.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Open up Newtork Servers from the menu.

Actual Results:  I got the message:
Couldn't display "smb:///", because Nautilus cannot contact the SMB
master browser.
Check that an SMB server is running in the local network.

Expected Results:  It should have browsed the network and found the
other computers on the network.  There are other computers (XP
computers) that have existing shares.

Additional info:
Comment 1 David Lawrence 2003-11-23 23:32:58 EST
Do you have a firewall enabled on your computer? To check, do 

service iptables stop

as root and try to browse again.
Comment 2 Brent Rowse 2003-11-24 17:38:48 EST
After stopping iptables, I am able to browse and see the network. 
Should I just turn off the iptables service?
Comment 3 David Lawrence 2003-11-24 17:47:53 EST
Well it is a "feature". You probably accepted the defaults during the
install on the firewall screen which is to block most open ports
including the ones needed by Samba to browse. You can do a 

chkconfig iptables off 

if you are sure you dont need a firewall or you can run the
redhat-config-security tool and open up the necessary ports to allow
for  Samba browsing and shares.
Comment 4 K Kane 2003-11-28 00:46:04 EST
I have a similar problem, except I don't get a warning, just an empty
smb:/// window.  I have stopped iptables and restarted smb, but I
still get no shares.  It works fine the other direction (I can browse
the network from XP), and I can smbmount from the command line, but
"Network Servers" from the menu gets me nada.
Comment 5 Chris Mathey 2004-02-09 21:48:05 EST
Was K Kane's problem resolved. I experience the same symptoms.
Comment 6 David Lawrence 2004-02-10 00:21:32 EST
Please attach your smb.conf file to this bug report for review.
Comment 7 Chris Mathey 2004-02-10 19:39:10 EST
Created attachment 97573 [details]
Samba Configuration File

All modifications to the original smb.conf ar those entries in the file
preceeded with the Commented Line "# Gawawh". I hope it is just a boring typo.
Some additional info: At installation the system name was 'train90', this has
been changed to 'Firewall' via :
System Tools -> Network -> DNS -> Hostname (was train90 changed to Firewall).
No DNS running, only set up as a DNS Client. I'm not sure if this would be of
any assistance, but past experience with node name changes has resulted in
erratic behavior.
Thank you for your assistance, and I hope it is just a boring 'typo'.
Comment 8 Bruce Reagan 2004-04-12 07:47:15 EDT
The iptables seem to make no difference.
XP can see redhat fine in network neighborhood.  Redhat can see XP and
itself through smbclient.
Comment 9 Need Real Name 2004-04-24 11:42:00 EDT
I had the same problem as Brent Rowse until I did "service iptables
stop". Then, I could view my network fine. However, I restarted
iptables with "service iptables start" and I can still see my network.
Comment 10 Need Real Name 2004-04-24 16:08:51 EDT
The way I fixed the problem is to add this line to

-A RH-Firewall-1-INPUT -i eth0 -j ACCEPT

then stop iptables, and start it. this should fix the problem
Comment 11 Marius Andreiana 2005-11-03 05:09:10 EST
As there wasn't any recent activity on this I'll mark as duplicate of a recent
bug with the same problem. 

Chris, Bruce please add yourselves as CC there and add any additional info you
have. Don't forget to have iptables off.

*** This bug has been marked as a duplicate of 168908 ***

Note You need to log in before you can comment on or make changes to this bug.