Bug 1106793 - icu: FTBFS in rawhide
Summary: icu: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: icu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eike Rathke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1106792 (view as bug list)
Depends On:
Blocks: F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 17:30 UTC by Dennis Gilmore
Modified: 2014-07-03 10:30 UTC (History)
3 users (show)

Fixed In Version: icu-52.1-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-03 10:30:00 UTC
Type: ---


Attachments (Terms of Use)
build.log (401.43 KB, text/plain)
2014-06-09 17:30 UTC, Dennis Gilmore
no flags Details
root.log (74.30 KB, text/plain)
2014-06-09 17:30 UTC, Dennis Gilmore
no flags Details
state.log (1.04 KB, text/plain)
2014-06-09 17:30 UTC, Dennis Gilmore
no flags Details
Patch to disable TestTwoDigitYear (501 bytes, patch)
2014-07-03 09:07 UTC, Zenon Panoussis
no flags Details | Diff

Description Dennis Gilmore 2014-06-09 17:30:30 UTC
Your package icu failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6986792

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 17:30:34 UTC
Created attachment 905314 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 17:30:38 UTC
Created attachment 905315 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 17:30:39 UTC
Created attachment 905316 [details]
state.log

Comment 4 Eike Rathke 2014-06-10 10:38:49 UTC
*** Bug 1106792 has been marked as a duplicate of this bug. ***

Comment 5 Eike Rathke 2014-06-10 10:55:07 UTC
Tail of build.log reads

make[2]: Leaving directory `/builddir/build/BUILD/icu/source/test/cintltst'
-------------
| ***     FAILING TEST SUMMARY FOR:              intltest  
         TestTwoDigitYear
      DateFormatTest
   format
| *** END FAILING TEST SUMMARY FOR:              intltest
---------------
ALL TESTS SUMMARY:
ok:  testdata iotest cintltst
===== ERRS:  intltest
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/icu/source/test'


So actually this is a test check failure that apparently worked before the mass rebuild. Can't say anything about it.

Comment 6 Eike Rathke 2014-06-13 17:41:56 UTC
Ok, this is http://sourceforge.net/p/icu/mailman/message/32443311/

Comment 7 Eike Rathke 2014-06-13 17:57:27 UTC
Fixed in icu-52.1-3.fc21

Comment 8 Zenon Panoussis 2014-07-03 09:07:55 UTC
Created attachment 914412 [details]
Patch to disable TestTwoDigitYear

Simple stopgap until upstream devises a more dynamic way to test for "last year". Tested, works.

Comment 9 Eike Rathke 2014-07-03 10:30:00 UTC
Instead of disabling the entire test, icu-52.1-3.fc21 has http://pkgs.fedoraproject.org/cgit/icu.git/diff/icu-testtwodigityear.patch


Note You need to log in before you can comment on or make changes to this bug.