Bug 110680 - crashes on startup in some environments (not default environment)
Summary: crashes on startup in some environments (not default environment)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-23 04:45 UTC by John Heidemann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 17:47:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace from gnumeric crash (313.60 KB, text/plain)
2003-11-23 04:49 UTC, John Heidemann
no flags Details
Backtrace with symbols (4.54 KB, text/plain)
2003-12-15 23:18 UTC, Tim Waugh
no flags Details

Description John Heidemann 2003-11-23 04:45:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Gnumeric crashes on startup when I run in my environment.
It starts fine if I run as a different (new) user on the same machine,
so clearly something about my world is non-standard.

Here's the traceback:

#0  0x00f9fc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x010079af in raise () from /lib/tls/libc.so.6
#2  0x01009322 in abort () from /lib/tls/libc.so.6
#3  0x00dc7f38 in g_logv () from /usr/lib/libglib-2.0.so.0
#4  0x00dc7f74 in g_log () from /usr/lib/libglib-2.0.so.0
#5  0x00650d98 in link_protocol_find_num ()
   from /usr/lib/libORBit-2.so.0
#6  0x006512f0 in link_servers_move_io_T ()
   from /usr/lib/libORBit-2.so.0
#7  0x00dbffdd in unblock_source () from /usr/lib/libglib-2.0.so.0
#8  0x00dc0fd8 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#9  0x00dc12ef in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#10 0x00dc19cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x0025844f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x09e583a0 in ?? ()

ldd on gnumeric looks normal (no libraries outside /usr/lib and /lib)

Since the bug is specific to my environment, I don't really expect any
follow-up on this.  (Status should probably just change to WORKSFORME)
But I wanted to document it in bugzilla in case someone else has the
same problem.


Version-Release number of selected component (if applicable):
gnumeric-1.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/gnumeric
2.
3.
    

Actual Results:  Crash into the bug-buddy window.

Expected Results:  Gnumeric window appears.

Additional info:

See description.

Comment 1 John Heidemann 2003-11-23 04:49:28 UTC
Created attachment 96144 [details]
strace from gnumeric crash

Comment 2 Tim Waugh 2003-12-15 22:48:48 UTC
I see this too.

Comment 3 Tim Waugh 2003-12-15 23:18:20 UTC
Created attachment 96549 [details]
Backtrace with symbols

Comment 4 Caolan McNamara 2004-05-03 23:22:23 UTC
caolanm->tim: Do you still see this problem ?

C.

Comment 5 Tim Waugh 2004-05-04 09:44:36 UTC
This seems to work in current devel.

Comment 6 Caolan McNamara 2004-05-06 17:47:05 UTC
ok, will close then. We're up to gnumeric-1.2.12 now.


Note You need to log in before you can comment on or make changes to this bug.