Bug 110687 - Procmail can't deliver mail to big mboxes
Procmail can't deliver mail to big mboxes
Status: CLOSED DUPLICATE of bug 88214
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procmail (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-23 08:49 EST by Matthew Booth
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2003-11-23 08:49:38 EST
Description of problem:

I noticed that a particular procmail rule for my RH mail was failing,
but the mail was being correctly delivered my catchall mbox.

In postfix's main.cf I have:
mailbox_command = /usr/bin/procmail -f- -a "$USER"

fetchmail delivers my RH mail to local user 'mbooth', which has a
procmail rule which delivers it to a local user 'matthew'.

In my procmail log for 'matthew' I kept seeing:

procmail: Error while writing to "RedHat"
procmail: Truncated file to former size
procmail: Unlocking "RedHat.lock"
procmail: Locking "INBOX.lock"
procmail: Assigning "LASTFOLDER=INBOX"
procmail: Opening "INBOX"
procmail: Acquiring kernel-lock
procmail: Unlocking "INBOX.lock"
procmail: Notified comsat: "matthew@8894602:/home/matthew/mail/INBOX"
From mbooth@matthew.revolutionwall.net  Sun Nov 23 12:16:59 2003
 Subject: weird procmail test 5
  Folder: INBOX                                                      
     2658

RedHat was 196MB. I moved a ton of it to an archive folder and with no
other modifications it is now correctly delivered.

Another weird thing is that if I did:

cat rh-test-mail | procmail -f- -a matthew

It worked, and was correctly delivered to the very large mbox. It was
only when called from postfix that the error occurred.

Version-Release number of selected component (if applicable):
procmail-3.22-9
postfix-2.0.11-4

How reproducible:

Always (for me).

Steps to Reproduce:
1. Create a really large mbox
2. Create a procmail rule to deliver mail to it
  
Actual results:

It fails

Expected results:

It doesn't fail :)

Additional info:

I've got a single big IDE disk. Filesystem is ext3 in LVM. Processor
is P42.4GHz with hyperthreading enabled.
Comment 1 Jens Petersen 2004-01-05 20:20:04 EST

*** This bug has been marked as a duplicate of 88214 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.