Bug 1106944 - Hostgroup parameters override button keep on creating new fields
Summary: Hostgroup parameters override button keep on creating new fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On: 1098776
Blocks: 1098777 1098782 1138470
TreeView+ depends on / blocked
 
Reported: 2014-06-09 18:42 UTC by Dominic Cleal
Modified: 2019-10-10 09:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1098782
Environment:
Last Closed: 2016-07-27 08:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Dominic Cleal 2014-06-09 18:42:23 UTC
+++ This bug was initially created as a clone of Bug #1098782 +++

Description of problem:
When trying to override a parameter under: configure-->hostgroups--> *hostgroup name*.
pressing the override button creates an entry at the bottom of the page to enter the value.
pressing the override button more than once keep on creating the same field, meaning, adding more row with the same parameter.

Regression: previously (former foreman) the override button showed some indication that the button had an effect (line over the text), currently there is no user feedback that pressing the button actuall did anything, resulting in the user pressing several times on the button.

fix: no "override" button required, instead of adding another line at the bottom, open the field for editing with default values.
OR 
make the override button open that field for editing instead of making the user scroll all the way down to edit.

Comment 2 Bryan Kearney 2015-02-18 23:03:02 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 3 Bryan Kearney 2015-03-19 10:02:03 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/4424 has been closed
-------------
Tom Caspy
Applied in changeset commit:0575b5b0a07c59c443bf2be663cb67d6a5e40f19.

Comment 4 Jitendra Yejare 2015-09-01 06:51:49 UTC
Please provide which fix is provided suggested in Description.
Or please provide the repro steps.

Comment 5 Tom Caspy 2015-09-01 07:25:42 UTC
I don't understand why this BZ ticket is related to the redmine ticket. They describe two completely separate issues in the same UI.

This issue should NOT be closed, and last time I checked it is actually still a bug on develop (and is being fixed as part of the parameter usability task)

Comment 6 Bryan Kearney 2015-09-01 08:00:49 UTC
Upstream bug component is WebUI

Comment 7 Bryan Kearney 2015-09-01 08:00:52 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/4424 has been closed
-------------
Tom Caspy
Applied in changeset commit:0575b5b0a07c59c443bf2be663cb67d6a5e40f19.

Comment 8 Tom Caspy 2015-09-01 08:34:03 UTC
link was wrong, changing status again and removing link to redmine issue.

Comment 10 orabin 2016-01-03 06:05:49 UTC
This was fixed upstream. It seems to be a mixture of: https://github.com/theforeman/foreman/pull/2649 and https://github.com/theforeman/foreman/pull/2927

This can  move to POST after both are in.

Comment 12 orabin 2016-01-03 06:30:55 UTC
Both the issues are already closed upstream so I'm moving this to POST.
The issues are:
http://projects.theforeman.org/issues/11464
http://projects.theforeman.org/issues/8799

Comment 15 Jitendra Yejare 2016-04-04 11:14:19 UTC
Verified this issue on Sat 6.2 snap 6.1 


I see on clicking multiple times on override button doesn't creates multiple rows to override the parameter as there is design change which is now disabling an enabling the text field to override the parameter.

So moving this but to Verified state.

Comment 18 errata-xmlrpc 2016-07-27 08:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.