Bug 1107042 - urbanlightscape: FTBFS in rawhide
Summary: urbanlightscape: FTBFS in rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: urbanlightscape
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker ARM64, F-ExcludeArch-aarch64 F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 19:12 UTC by Dennis Gilmore
Modified: 2015-08-13 16:54 UTC (History)
2 users (show)

Fixed In Version: urbanlightscape-1.3.3-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-03 19:06:39 UTC


Attachments (Terms of Use)
build.log (378.83 KB, text/plain)
2014-06-09 19:12 UTC, Dennis Gilmore
no flags Details
root.log (109.59 KB, text/plain)
2014-06-09 19:12 UTC, Dennis Gilmore
no flags Details
state.log (1.09 KB, text/plain)
2014-06-09 19:12 UTC, Dennis Gilmore
no flags Details
Patch for rawhide (1.50 KB, patch)
2014-06-19 04:51 UTC, Yaakov Selkowitz
no flags Details | Diff

Description Dennis Gilmore 2014-06-09 19:12:36 UTC
Your package urbanlightscape failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6998284

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 19:12:42 UTC
Created attachment 905915 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 19:12:44 UTC
Created attachment 905916 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 19:12:45 UTC
Created attachment 905917 [details]
state.log

Comment 4 Yaakov Selkowitz 2014-06-19 04:49:23 UTC
One header (src/indii/krig/EdgeDistanceMap.hpp) uses <xmmintrin.h>, which is not available on arm or other secondary arches.

Comment 5 Yaakov Selkowitz 2014-06-19 04:51:06 UTC
Created attachment 910246 [details]
Patch for rawhide

Patch to mark this package ExclusiveArch.

Comment 6 Yaakov Selkowitz 2014-07-08 21:57:18 UTC
SSE is required for xmmintrin.h, so you will need to leave those flags in the Makefiles in order for this to build on ix86.

Comment 7 Christopher Meng 2015-02-26 03:22:43 UTC
(In reply to Yaakov Selkowitz from comment #6)
> SSE is required for xmmintrin.h, so you will need to leave those flags in
> the Makefiles in order for this to build on ix86.

I originally wanted to disable sse2 support as upstream told me without this urbanlightscape could run but slower(~1/4 of speed with sse2), and now that arm is already slow enough, I decide to disable builds on arm and then find if we can port this to NEON.

Built for f22 f21 and f20, but f23 failed as pow in libm couldn't be found, I guess it's caused by the mess on rawhide.

Comment 8 Ralf Corsepius 2015-07-03 19:06:39 UTC
Fixed in rawhide:
http://koji.fedoraproject.org/koji/buildinfo?buildID=666873

The cause for the FTBFS is a broken configure script, which drop CXXFLAGS during some config-checks.

Comment 9 Fedora Update System 2015-07-03 19:47:07 UTC
urbanlightscape-1.3.3-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/urbanlightscape-1.3.3-3.fc21

Comment 10 Fedora Update System 2015-07-03 19:47:13 UTC
urbanlightscape-1.3.3-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/urbanlightscape-1.3.3-3.fc22

Comment 11 Fedora Update System 2015-08-07 13:07:27 UTC
urbanlightscape-1.3.3-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-08-13 16:54:57 UTC
urbanlightscape-1.3.3-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.