Bug 1107044 - ruby: FTBFS in rawhide
Summary: ruby: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 19:12 UTC by Dennis Gilmore
Modified: 2014-06-27 12:58 UTC (History)
12 users (show)

Fixed In Version: ruby-2.1.2-23.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-27 12:58:20 UTC


Attachments (Terms of Use)
build.log (1.06 MB, text/plain)
2014-06-09 19:13 UTC, Dennis Gilmore
no flags Details
root.log (89.82 KB, text/plain)
2014-06-09 19:13 UTC, Dennis Gilmore
no flags Details
state.log (1.06 KB, text/plain)
2014-06-09 19:13 UTC, Dennis Gilmore
no flags Details
Enable tcl/tk 8.6 compilation (534 bytes, patch)
2014-06-10 14:07 UTC, Vít Ondruch
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Ruby 9743 None None None Never
Ruby 9984 None None None Never

Description Dennis Gilmore 2014-06-09 19:12:59 UTC
Your package ruby failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6998619

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 19:13:08 UTC
Created attachment 905921 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 19:13:11 UTC
Created attachment 905922 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 19:13:12 UTC
Created attachment 905923 [details]
state.log

Comment 4 Vít Ondruch 2014-06-10 14:07:46 UTC
Created attachment 907283 [details]
Enable tcl/tk 8.6 compilation

Comment 5 Vít Ondruch 2014-06-10 14:09:21 UTC
Although I can convince Ruby to compile against newer Tcl/Tk, the Tcl/Tk extension just segfaults. May by Tcl/Tk maintainer can have some idea ...

Comment 6 Jaroslav Škarvada 2014-06-13 13:46:43 UTC
(In reply to Vít Ondruch from comment #5)
> Although I can convince Ruby to compile against newer Tcl/Tk, the Tcl/Tk
> extension just segfaults. May by Tcl/Tk maintainer can have some idea ...

Actually there are two problems (at least :)

a) tcl/tk need to be build with threads
- this has been recently fixed in rawhide. By rebuilding against tcl-8.6.1-5 / tk-8.6.1-2 simple samples from the ruby sources stop segfaulting.

b) ruby needs to be patched not to segfault on reproducer from: https://bugs.ruby-lang.org/issues/8000
- I guess this is caused the way how ruby hacks the stack, there were some related changes in tcl/tk-8.6. I will try to look on it more deep.

Comment 7 Yaakov Selkowitz 2014-06-25 22:20:32 UTC
2.1.2-23 fixed i686 and x86_64, but not armv7hl:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7074012

Error:
OpenSSL::TestPKeyRSA#test_sign_verify_memory_leak:
Timeout::Error: execution of assert_no_memory_leak expired
    /builddir/build/BUILD/ruby-2.1.2/test/openssl/test_pkey_rsa.rb:80:in `test_sign_verify_memory_leak'
15006 tests, 2462554 assertions, 0 failures, 1 errors, 31 skips

Comment 8 Vít Ondruch 2014-06-26 08:41:05 UTC
Seems to be related to this issue: https://bugs.ruby-lang.org/issues/9743

Comment 9 Yaakov Selkowitz 2014-06-26 20:41:40 UTC
(In reply to Vít Ondruch from comment #8)
> Seems to be related to this issue: https://bugs.ruby-lang.org/issues/9743

Possibly, but why would only armv7hl be affected?

Comment 10 Yaakov Selkowitz 2014-06-27 00:38:26 UTC
(In reply to Vít Ondruch from comment #8)
> Seems to be related to this issue: https://bugs.ruby-lang.org/issues/9743

Sorry, I misread this at first.  This commit is actually part of 2.1.2, and it's the new tests within which are timing out.  Given that the test uses 20,000 iterations, it's not really surprising that only armv7hl is affected, given that at least some of those units are much slower than an i686.

Cutting that down to 10,000 iterations was successful in a scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7081290

Although I do wonder how reliable even that will be.

Comment 11 Vít Ondruch 2014-06-27 12:58:20 UTC
(In reply to Yaakov Selkowitz from comment #10)
> Cutting that down to 10,000 iterations was successful in a scratch build:

I guess this is good at least as a workaround, so I applied it and build Ruby. Will see what upstream thinks about it:

https://bugs.ruby-lang.org/issues/9984

Thanks!


Note You need to log in before you can comment on or make changes to this bug.