Bug 110715 - Upgrade fails: error transferring install image
Upgrade fails: error transferring install image
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-23 20:06 EST by Charlie Brady
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Brady 2003-11-23 20:06:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031027

Description of problem:
When attempting to upgrade fedora 0.95 to FC 1, the installer bails
reporting:

 An error occurred transferring the install image to your hard drive.
 You are probably out of disk space.

I have 18G free, so I'm not out of disk space.

The last message on VT1 is:

Error loading new keyboard definition

There is no shell running on VT2.

Last message on VT3 is:

moving(1) to step preinstallconfig

Last message on VT4 is:

<6>Adding swap: 1044216K swap-space


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Stick CD1 in and try to upgrade my system :-) 

Additional info:

I verified all 3 CDRs, so it's not a media problem. I don't know where
to look - any suggestions?
Comment 1 Jeremy Katz 2003-11-24 17:12:23 EST
Does booting with 'linux allowcddma' help? 
Comment 2 Charlie Brady 2003-11-25 18:41:00 EST
> Does booting with 'linux allowcddma' help?

Yes ... and no.

One system upgraded fine with the additional option. Another (actually
the same system, with a different hard drive) still reported an error
in transferring the install image. On that system, VT2 showed:

-/bin/sh: relocation error: -/bin/sh: symbol, version GLIBC_2.0 not
defined in file libc.so.6 with link time reference

I tried that one again without "allowcddma" and it showed the same
error message on VT2 (instead of shell prompt), so I assume that is
another problem.
Comment 3 Matteo Bertamini 2003-11-29 20:45:27 EST
I try to install Fedora Core 1 without upgrading my system and I have 
the same problem while anaconda trasfering the install image :-(.
How I can do to step this problem? :\
Comment 4 Need Real Name 2004-05-11 21:31:53 EDT
"linux allowcddma" worked for me. What's the cause?
Comment 5 Jeremy Katz 2004-10-05 11:44:27 EDT
This was caused by a kernel bug in the Fedora Core 1 kernel that is no
longer an issue in newer releases with the 2.6 kernel.

Note You need to log in before you can comment on or make changes to this bug.