Bug 1107327 - Cannot provision systems via capsule content
Summary: Cannot provision systems via capsule content
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule   
(Show other bugs)
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1030584
TreeView+ depends on / blocked
 
Reported: 2014-06-09 22:41 UTC by Corey Welton
Modified: 2016-04-22 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 14:06:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6145 None None None 2016-04-22 15:37 UTC

Description Corey Welton 2014-06-09 22:41:36 UTC
Description of problem:
When users configure capsules as their puppet master/puppet ca, content is still pulled from main sat to populate new VMs.  This is because the content source on the sat itself is, for the most part, hardcoded to the path on the sat.  There is no way to point this to capsule.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140605.0
How reproducible:


Steps to Reproduce:
1.  Create and sync content to a capsule
2.  Create a hostgroup, etc., pointing to your capsule for puppet master/ca
3.  Try to create a new libvirt host using the hostgroup above

Actual results:
Notification in main sat logs:
D, [2014-06-09T21:38:46.592955 #23661] DEBUG -- : Starting task (total: 0): /usr/bin/wget --timeout=10 --tries=3 --no-check-certificate -nv -c http://ibm-x3550m3-07.lab.eng.brq.redhat.com/pulp/repos/ACME_Corporation/dev/6ServerAndSatTake2/content/dist/rhel/server/6/6Server/x86_64/kickstart//images/pxeboot/vmlinuz -O "/var/lib/tftpboot//boot/RedHat-6.5-x86_64-vmlinuz"
D, [2014-06-09T21:38:46.660651 #23661] DEBUG -- : Starting task (total: 0): /usr/bin/wget --timeout=10 --tries=3 --no-check-certificate -nv -c http://ibm-x3550m3-07.lab.eng.brq.redhat.com/pulp/repos/ACME_Corporation/dev/6ServerAndSatTake2/content/dist/rhel/server/6/6Server/x86_64/kickstart//images/pxeboot/initrd.img -O "/var/lib/tftpboot//boot/RedHat-6.5-x86_64-initrd.img"


Expected results:
Content being pulled from capsule instead of main sat.

This is due to the fact that the content sources (As created when publishing/promoting a content view and thus getting installation media) are hard-coded to the satellite itself:


ACME_Corporation/dev/6ServerAndSatTake2 RedHat Server 6.5 x86_64

http://ibm-x3550m3-07.lab.eng.brq.redhat.com/pulp/repos/ACME_Corporation/dev/6ServerAndSatTake2/content/dist/rhel/server/6/6Server/x86_64/kickstart/

There is no way to point to capsule content as a source for kickstarts. In theory it might be possible to manually do so, but that is ugly -- not to mention if a user has a dozen capsules with a bunch of content sources, it will quickly become unwieldy.


Additional info:

Comment 2 Brad Buckingham 2014-06-13 20:14:00 UTC
Assigning to Joseph as his work to associate capsule to host and hostgroup (for pulp feature) should address this.

Comment 3 Justin Sherrill 2014-06-18 14:47:24 UTC
Connecting redmine issue http://projects.theforeman.org/issues/6145 from this bug

Comment 4 Bryan Kearney 2014-06-20 14:04:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6145 has been closed

Comment 7 Corey Welton 2014-06-27 13:44:49 UTC
Verified in Satellite-6.0.3-RHEL-6-20140626.1.  Woohoo!

Comment 8 Bryan Kearney 2014-07-02 14:06:55 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.