Bug 110751 - broken source code
broken source code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 08:58 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-06 07:47:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 08:58:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package ghostscript-7_07-11 from Fedora.

The compiler said

./src/sdcparam.c(161): remark #592: variable "quant_tables" is used 
before its value is set

The source code is

    gs_param_array quant_tables;

	/* more code */

    num_in_tables = quant_tables.size;

Seems like a pretty obvious bug to me.



Version-Release number of selected component (if applicable):
ghostscript-7_07-11 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Tim Waugh 2003-12-05 11:08:07 EST
It's very far from clear what the fix is, and the comment immediately
above that line indicates that someone else found the problem and is
also not sure what to do.  Since it's known upstream, I'm closing this.
Comment 2 d.binderman 2003-12-06 04:26:26 EST
>It's very far from clear what the fix is, 

Fair enough - not all bugs are easy to fix.

>someone else found the problem and is also not sure what to do

fair enough - two people don't know how to fix it.

>Since it's known upstream, I'm closing this

I am unhappy with this. I think the bug needs fixing, independent
of whether two people don't know what the fix is.

Does it only get fixed if the fix is easy ?

Comment 3 Tim Waugh 2003-12-06 07:47:56 EST
It's not even clear that this is a code path that gets executed.  If
it had been causing some outrageous symptom it might be worth spending
some time working on.  Best worked on by those who know the code best,
upstream.

Note You need to log in before you can comment on or make changes to this bug.