Bug 1107641 - no normal way to get VNC password for guests being provisioned on libvirt compute resource
Summary: no normal way to get VNC password for guests being provisioned on libvirt com...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom Caspy
QA Contact: Stephen Benjamin
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-10 11:34 UTC by Jan Hutař
Modified: 2019-09-26 17:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 20:09:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
password not expandable (17.51 KB, image/png)
2016-03-24 19:40 UTC, Stephen Benjamin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6371 0 None None None 2016-04-22 16:51:57 UTC

Description Jan Hutař 2014-06-10 11:34:33 UTC
Description of problem:
There is no normal way to get VNC password for guests being provisioned on libvirt compute resource


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140605.0


How reproducible:
always


Steps to Reproduce:
1. Setup Satellite 6 to the state you can provision guests on local
   libvirt compute resource
2. Provision some guest using network install
3. Attempt to access console of the guest via virt-manager on the host
   which is provisioning the guest


Actual results:
You are asked for password and I have not found way to obtain the password from webUI


Expected results:
Password should be either configurable or accessible via webUI


Additional info:
You can find password in:

  Ifrastructure -> Compute Resources -> <libvirt_compute_resource> ->
  -> Virtual Machines -> <your_machine> -> [Console]

now display HTML source of the page and find "data-password"

Comment 2 Dominic Cleal 2014-06-25 07:04:02 UTC
Created redmine issue http://projects.theforeman.org/issues/6371 from this bug

Comment 3 Bryan Kearney 2015-02-10 11:02:23 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6371 has been closed
-------------
Tom Caspy
Applied in changeset commit:e2328c6d77fd1cfec3f045200b7a17d5f252c32a.

Comment 4 Bryan Kearney 2015-02-18 22:21:39 UTC
Upstream bug assigned to tcaspy

Comment 6 Stephen Benjamin 2016-03-24 19:40:37 UTC
Created attachment 1140105 [details]
password not expandable

Comment 7 Stephen Benjamin 2016-03-24 19:40:56 UTC
Failed.

"Password " shows up, but you can't expand it to view it - see screenshot.

Comment 8 Bryan Kearney 2016-03-24 20:13:03 UTC
Upstream bug component is Compute Resources

Comment 11 Bryan Kearney 2016-04-18 12:16:34 UTC
Upstream bug assigned to tcaspy

Comment 12 Bryan Kearney 2016-04-26 14:16:27 UTC
Upstream bug assigned to tcaspy

Comment 13 Bryan Kearney 2017-03-13 20:09:24 UTC
This has been copied to an issue upstream. When the upstream issue is fixed, the next version of satellite will contain it. We will no longer track this downstream.


Note You need to log in before you can comment on or make changes to this bug.