Bug 110767 - bad source code
bad source code
Status: CLOSED DUPLICATE of bug 82189
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 10:18 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 10:18:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package mysql-3_23_58-2 from Fedora.

The compiler said

1.

log0recv.c:1384: warning: too few arguments for format
log0recv.c:1401: warning: too few arguments for format
log0recv.c:1429: warning: too few arguments for format

The source code is

                                printf(
"InnoDB: Error: cannot open %lu'th data file %s\n", nth_file);


and

                                printf(
"InnoDB: Error: cannot read page no %lu from %lu'th data file %s\n",
                                nth_page_in_file, nth_file);

and
                                printf(
"InnoDB: Error: cannot write page no %lu to %lu'th data file %s\n",
                                nth_page_in_file, nth_file);



Sounds like printf % specifier / parameter mismatch.


Version-Release number of selected component (if applicable):
mysql-3_23_58-2 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Patrick Macdonald 2003-11-24 10:26:35 EST

*** This bug has been marked as a duplicate of 82189 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.