Bug 110800 - bad source code
bad source code
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: imap (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 11:20 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 10:20:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:20:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package imap-2002d-3 from Fedora.

The compiler said

env_unix.c(1180): warning #187: use of "=" where "==" may have been 
intended

The source code is

          (read (fd,tmp,i) == i) && !(tmp[i] = 0) && ((i = atol 
(tmp)) > 0))

Might be better off with

          (read (fd,tmp,i) == i) 
			&& !(tmp[i] == 0) && ((i = atol (tmp)) > 0))



Version-Release number of selected component (if applicable):
imap-2002d-3 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Kenneth Porter 2004-01-23 21:25:29 EST
The code is ugly, but the assignment looks correct.

Untested, but to eliminate the warning, replace the expression
"!(tmp[i]=0)" with "(0 == (tmp[i] = 0))". (This is just
null-terminating the buffer before running atol.) Still ugly, but it
should eliminate the warning.
Comment 2 John Dennis 2004-01-27 10:20:28 EST
This is not a Red Hat issue but rather an upstream issue for the UW
imap authors. If you would like to address this in the UW Imap forum
you may do so, discussion occurs on the c-client list and you can find
sign up information here: http://www.washington.edu/imap

Note You need to log in before you can comment on or make changes to this bug.