Bug 1108028 - ciphers(1) man page lacks description of ECC and TLSv1.2 suites
Summary: ciphers(1) man page lacks description of ECC and TLSv1.2 suites
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On: 1108026
Blocks: 1119191
TreeView+ depends on / blocked
 
Reported: 2014-06-11 10:34 UTC by Hubert Kario
Modified: 2014-10-14 07:27 UTC (History)
4 users (show)

(edit)
Cause: man ciphers did not describe either ECC cipher suite groups (ECDH, ECDSA) or TLSv1.2 specific features

Consequence: incomplete documentation

Fix: add missing description of cipher groups and features

Result: updated documentation
Clone Of: 1108026
(edit)
Last Closed: 2014-10-14 07:27:18 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description Hubert Kario 2014-06-11 10:34:49 UTC
Description of problem:
`man ciphers` does not describe either ECC cipher suite groups (ECDH, ECDSA) or TLSv1.2 specific features

Version-Release number of selected component (if applicable):
openssl-1.0.1e-16.el6_5.14

How reproducible:
Always

Steps to Reproduce:
1. man ciphers
2. search for "ECDH", "TLSv1.2" or "AESGCM"

Actual results:
None of those are mentioned or documented

Expected results:
all supported ECC and TLSv1.2 cipher suite groups documented

Additional info:
Fixed in upstream: https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=87887a7a658bf305bfe6619eedcbc6c3972cc188

Comment 8 errata-xmlrpc 2014-10-14 07:27:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.