Bug 1108095 - rhq.storage.request.limit is overridden by rhq.storage.request.limit.topology-delta on start-up
Summary: rhq.storage.request.limit is overridden by rhq.storage.request.limit.topology...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Configuration, Storage Node
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On: 1146138
Blocks: 1098243
TreeView+ depends on / blocked
 
Reported: 2014-06-11 12:50 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:02 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:43 UTC


Attachments (Terms of Use)
default_throttling.log (41.86 KB, text/x-log)
2014-06-11 12:50 UTC, Armine Hovsepyan
no flags Details
rhq.storage.request.limit.topology-delta (230.16 KB, image/png)
2014-10-07 13:26 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-06-11 12:50:13 UTC
Created attachment 907620 [details]
default_throttling.log

Description of problem:
rhq.storage.request.limit is overridden by rhq.storage.request.limit.topology-delta on start-up

Version-Release number of selected component (if applicable):
rhq master 

How reproducible:
always

Steps to Reproduce:
1. install rhq server, storage and agent
2. stop services by rhqctl stop
3. change the default throttling values so that e.g.
rhq.storage.request.limit=5000
rhq.storage.request.limit.topology-delta=3000
4. call rhqctl start

Actual results:
rhq.storage.request.limit is overridden by rhq.storage.request.limit.topology-delta on start-up

Expected results:
rhq.storage.request.limit is NOT overridden by rhq.storage.request.limit.topology-delta on start-up

Additional info:
see attached the value change log

Comment 1 Michael Burman 2014-09-12 07:02:53 UTC
To me this seems intentional, I'm not sure if we need request.limit at all? The idea seems to be that we increase the request limit based on the amount of nodes up. rhq.storage.request.limit is only used to initialize RateLimiter, but then it is instantly overridden with calculated value.

John, was the plan to use storage-limit as hard-quota or is it just something left over from the past?

Comment 3 Michael Burman 2014-09-26 11:18:10 UTC
Work is now done in PR 131.

Comment 4 Michael Burman 2014-09-26 19:58:06 UTC
Fixed in master:

commit 328cecabaa662cccc0f1d136576c2883c45ca54a
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 26 14:08:35 2014 +0300

    [BZ 1108095] Updating topology delta will automatically change requestLimit. RequestLimit is no longer allowed to be edited directly

commit 6958d627983c66813ad12f0e7b42619ddbdfe7b0
Author: John Sanda <jsanda@redhat.com>
Date:   Fri Sep 26 11:25:50 2014 -0400

    [BZ 1108095] fix compiler errors

commit c6b482c1b687d70d7644ba91dd6c272f701cfd07
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 26 17:36:27 2014 +0300

    [BZ 1108095] Use topologyDelta instead of hard requestLimit for tests

Comment 5 Michael Burman 2014-09-26 20:03:16 UTC
After discussion with jsanda, cherry-picked to release/jon3.3.x:

commit cf00bbefe39eb8fe1ecb167e6a3a3238fd0ab0b4
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 26 14:08:35 2014 +0300

    [BZ 1108095] Updating topology delta will automatically change requestLimit. RequestLimit is no longer allowed to be edited directly
    
    (cherry picked from commit 328cecabaa662cccc0f1d136576c2883c45ca54a)

commit d20de2f433c98659e3b0edf4ad772a51863c6c7e
Author: John Sanda <jsanda@redhat.com>
Date:   Fri Sep 26 11:25:50 2014 -0400

    [BZ 1108095] fix compiler errors
    
    (cherry picked from commit 6958d627983c66813ad12f0e7b42619ddbdfe7b0)

commit 3233bd4902c80f2fba7b15c51bb171fcb15d27ac
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 26 17:36:27 2014 +0300

    [BZ 1108095] Use topologyDelta instead of hard requestLimit for tests
    
    (cherry picked from commit c6b482c1b687d70d7644ba91dd6c272f701cfd07)

Comment 6 Simeon Pinder 2014-10-01 21:33:02 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 7 Armine Hovsepyan 2014-10-07 13:25:39 UTC
verified in JON 3.3 ER04
screen-shot attached

Comment 8 Armine Hovsepyan 2014-10-07 13:26:53 UTC
Created attachment 944584 [details]
rhq.storage.request.limit.topology-delta


Note You need to log in before you can comment on or make changes to this bug.