Bug 1108099 - Unable to create host without Puppet master when specified on host group
Summary: Unable to create host without Puppet master when specified on host group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-11 12:52 UTC by Martin Korbel
Modified: 2019-09-26 17:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:41:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
removed the puppet_ca and master association from new host (which was inherited from hostgroup) (63.03 KB, image/png)
2016-04-14 12:23 UTC, Sachin Ghai
no flags Details
host was created succesfully (83.27 KB, image/png)
2016-04-14 12:24 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6369 None None None 2016-04-22 16:13:34 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Martin Korbel 2014-06-11 12:52:27 UTC
Description of problem:
I detected the problem with switch off the  puppet  in the provisioning form ("Hosts" > "New host"). Satellite ignores my choice of puppet options in "New host" form and it uses configuration from host group.

Version-Release number of selected component (if applicable):
katello-1.5.0-25.el6sat
foreman-1.6.0.14-1.el6sat

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat6.0.3 with some compute resource (in my case RHEV)
2. We create new host group ("Configure" > "Host Groups" > "New Host Group") and choose some "Puppet CA" and "Puppet Master".
3. We create new guest (in my case RHEV) and we choose our new host group in the selectbox "Host Group"
4. We try to disable puppet, choose empty line for "Puppet CA" and "Puppet Master".

Actual results:
In my case, I had a bad configuration of puppet and I got this error in the log file /var/log/foreman/production.log. When I deselect "Puppet CA" and "Puppet Master" in the host group, everything works well.

> Operation FAILED: ERF12-0104 [ProxyAPI::ProxyException]: Unable to set  PuppetCA autosign for rhev11.test.example.com ([RestClient::ResourceNotFound]: 404 Resource Not Found) for proxy https://sat6.redhat.com:9090/puppet/ca
Completed 500 Internal Server Error in 418ms


Expected results:
The configuration in the new host form, it will have higher priority than configuration from host group (especially puppet options).

Additional info:

Comment 1 RHEL Program Management 2014-06-11 13:09:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-06-25 06:54:29 UTC
Created redmine issue http://projects.theforeman.org/issues/6369 from this bug

Comment 4 Bryan Kearney 2015-01-20 09:02:18 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6369 has been closed
-------------
Tom Caspy
Applied in changeset commit:5e1f3b716878b5347a474e1efc7f71f256fd2d75.

Comment 5 Bryan Kearney 2015-02-18 22:21:41 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 8 Sachin Ghai 2016-04-14 12:18:41 UTC
Verified with sat6.2 beta snap7.1


The reported issue is no longer reproducible. I created a hostgroup with association of puppet CA and puppet master. Later, when I tried to create new host, I removed the puppet CA and master association from new host form and submitted the form. Host was created successfully without any issue.


2016-04-14 08:13:29 [app] [I] Processing by HostsController#create as */*
2016-04-14 08:13:29 [app] [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"8nuAQlv6TMQHPTnWSYpNwoQAYKLKLHWeggJQqCE1BvQ=", "host"=>{"name"=>"testhg", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"2", "compute_resource_id"=>"1", "content_facet_attributes"=>{"lifecycle_environment_id"=>"2", "content_view_id"=>"3", "id"=>""}, "environment_id"=>"1", "content_source_id"=>"1", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "openscap_proxy_id"=>"", "puppetclass_ids"=>[""], "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "interfaces_attributes"=>{"0"=>{"_destroy"=>"0", "type"=>"Nic::Managed", "mac"=>"", "identifier"=>"", "name"=>"testhg", "domain_id"=>"1", "subnet_id"=>"1", "ip"=>"10.8.111.14", "managed"=>"1", "primary"=>"1", "provision"=>"1", "execution"=>"1", "virtual"=>"0", "tag"=>"", "attached_to"=>"", "compute_attributes"=>{"name"=>"nic1", "network"=>"737353a9-dff8-44d7-bd64-de9c9edd6fda"}}}, "compute_attributes"=>{"cluster"=>"00000001-0001-0001-0001-00000000022f", "template"=>"00000000-0000-0000-0000-000000000000", "cores"=>"1", "memory"=>"1073741824", "start"=>"1", "volumes_attributes"=>{"new_1460635969321"=>{"_delete"=>"", "size_gb"=>"10", "storage_domain"=>"af918214-e6b2-4a01-a960-73dbc06a7073", "id"=>"", "preallocate"=>"0"}}}, "architecture_id"=>"1", "operatingsystem_id"=>"3", "provision_method"=>"build", "build"=>"1", "medium_id"=>"", "ptable_id"=>"61", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"3-Users", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}, "capabilities"=>"build image", "provider"=>"Ovirt", "bare_metal_capabilities"=>"build"}
2016-04-14 08:13:29 [app] [I] Started GET "/foreman_tasks/tasks/7ad12c44-8dc1-4668-a1e9-6c34b739f725" for 10.65.193.134 at 2016-04-14 08:13:29 -0400
2016-04-14 08:13:29 [app] [I] Processing by ForemanTasks::TasksController#show as HTML
2016-04-14 08:13:29 [app] [I]   Parameters: {"id"=>"7ad12c44-8dc1-4668-a1e9-6c34b739f725"}
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/_details.html.erb (214.4ms)
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/_running_steps.html.erb (12.8ms)
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/_errors.html.erb (4.7ms)
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/_raw.html.erb (13.5ms)
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/_locks.html.erb (16.8ms)
2016-04-14 08:13:29 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.7.14.2/app/views/foreman_tasks/tasks/show.html.erb within layouts/application (315.8ms)
2016-04-14 08:13:29 [app] [I]   Rendered layouts/_application_content.html.erb (1.3ms)
2016-04-14 08:13:29 [app] [I]   Rendered home/_submenu.html.erb (3.3ms)
2016-04-14 08:13:29 [app] [I]   Rendered home/_user_dropdown.html.erb (4.3ms)
2016-04-14 08:13:29 [app] [I] Read fragment views/tabs_and_title_records-3 (0.5ms)
2016-04-14 08:13:29 [app] [I]   Rendered home/_topbar.html.erb (12.3ms)
2016-04-14 08:13:29 [app] [I]   Rendered layouts/base.html.erb (16.1ms)
2016-04-14 08:13:29 [app] [I] Completed 200 OK in 383ms (Views: 336.1ms | ActiveRecord: 16.9ms)

Comment 9 Sachin Ghai 2016-04-14 12:23:19 UTC
Created attachment 1147227 [details]
removed the puppet_ca and master association from new host (which was inherited from hostgroup)

Comment 10 Sachin Ghai 2016-04-14 12:24:04 UTC
Created attachment 1147229 [details]
host was created succesfully

Comment 13 errata-xmlrpc 2016-07-27 08:41:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.