Bug 110811 - bad source code
bad source code
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gsl (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 11:39 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 09:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:39:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package gsl-1_4-1 from Fedora.

The compiler said

1.

bessel_y.c(84): warning #239: floating point underflow
bessel_y.c(84): warning #239: floating point underflow

The source code is

  else if(1.0/GSL_DBL_MAX > 0.0 && x < 1.0/GSL_DBL_MAX) {

I am not sure what a fix for this might be.

2.

coulomb.c(994): remark #592: variable "G_lam_G" is used before its 
value is set
coulomb.c(996): remark #592: variable "Gp_lam_G" is used before its 
value is set

This seems to be a problem in some "can never happen" code. I'm not 
sure
what the fix is for this.



Version-Release number of selected component (if applicable):
gsl-1_4-1 

How reproducible:
Always

Steps to Reproduce:
1. compile the program
2.
3.
    

Additional info:
Comment 1 Ivana Varekova 2004-12-01 09:00:24 EST
Thank you for your notice. 
1/ Program predict this alternative too.
2/ Lines 994 and 996 will never happend.
It is not a bug.
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.