Bug 110812 - bad source code
bad source code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Mike McLean
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2003-11-24 11:45 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 05:35:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:45:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package groff-1_18_1-29 from Fedora.

The compiler said

1.

draw.c(421): warning #165: too few arguments in function call

The source code is
                        DoCharacter (dw, code, wid);

but the definition of DoCharacter is

static void
#ifdef ENABLE_MULTIBYTE
DoCharacter (dw, c, wid, char2xchar2b)
#else
DoCharacter (dw, c, wid)
#endif

it looks like someone is missing some support for multi-byte 
characters.

2.

draw.c(432): warning #165: too few arguments in function call

Same problem as #1.


Version-Release number of selected component (if applicable):
groff-1_18_1-29 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Thomas Woerner 2004-09-16 05:35:19 EDT
Fixed in rawhide in rpm groff-1.18.1.1-2 or newer.

Note You need to log in before you can comment on or make changes to this bug.