Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1108174

Summary: [engine-backend] [iSCSI multipath] Required cluster network shouldn't be allowed to be added to an iSCSI multipath bond
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engineAssignee: Sergey Gotliv <sgotliv>
Status: CLOSED ERRATA QA Contact: Aharon Canan <acanan>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: acathrow, amureini, ebenahar, ederevea, iheim, lpeer, Rhev-m-bugs, scohen, sgotliv, tnisan, tpoitras, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: 3.4.1   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: storage
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, it was possible to add a required network to an iSCSI multipath bond. Since required networks are mandatory for the cluster, this caused the host to enter a non-operational state if it lost one of the networks configured in its iSCSI bond. Now, it is no longer possible to add a required network to an iSCSI multipath bond.
Story Points: ---
Clone Of: 1093393 Environment:
Last Closed: 2014-07-29 16:24:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1093393    
Bug Blocks:    

Comment 2 Elad 2014-06-29 09:19:00 UTC
Required networks are not allowed to be part of an iSCSI bond.
CDA:

2014-06-29 12:16:09,244 WARN  [org.ovirt.engine.core.bll.storage.AddIscsiBondCommand] (ajp-/127.0.0.1:8702-6) [12549b41] CanDoAction of action AddIscsiBond failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__ISCSI_BOND,ACTION_TYPE_FAILED_ISCSI_BOND_NETWORK_CANNOT_BE_REQUIRED

Message presented in webadmin:

Operation Canceled
Error while executing action: Cannot add iSCSI Bond. Required network cannot be a part of an iSCSI bond.




Checked using rhev-3.4.1-av10
rhevm-3.4.1-0.23.el6ev.noarch

Comment 4 errata-xmlrpc 2014-07-29 16:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0960.html