Bug 1108252 - New Host: selection of "Host Group" and "Deploy on" is user-unfriendly
Summary: New Host: selection of "Host Group" and "Deploy on" is user-unfriendly
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ondřej Pražák
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-11 15:26 UTC by Corey Welton
Modified: 2019-04-01 20:27 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-27 11:38:17 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6167 None None None 2016-04-22 16:39 UTC

Description Corey Welton 2014-06-11 15:26:19 UTC
Description of problem:
The contents of "Host Group" affects the contents of the two drop downs ("Environment", "Content View")that exist below the "Deploy on" field. As such, these three fields should be grouped together.  A side effect of this, however, is  that if user selects a group and then quickly selects a provisioning type ("Deploy on"), the UI gets refreshed after group/environment/content view are populated, and the user's selection is reset.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140605.0

How reproducible:


Steps to Reproduce:
1.  Assure you have at least one host group created and at least one provisioning type other than baremetal created (i.e., libvirt)
2.  Hosts > New Host 
3.  begin populating fields;  choose a group from your Host Groups list and then quickly select a provisioning type in "Deploy on". 
4.  Wait for UI to refresh with contents for Environment, Content View;  observe results.

Actual results:
Once the appropriate values are auto-filled -- i.e., the page has been refreshed -- the user's deploy method selection has been reset.

Expected results:
Something a little more user-friendly.  Reversing the location of these two fields solves two issues:
* It appropriately positions the "Host Group" field with the two accompanying fields that rely on its input
* It makes it much less likely that user's selection for "Deploy on" gets reset.


Additional info:
Current workaround is to select "deploy on" method first, or simply wait for UI to completely refresh after selecting Host Group.

Comment 2 Dominic Cleal 2014-06-11 15:44:09 UTC
The fields are laid out this way deliberately, as this is a performance enhancement and it'll be much slower if swapped back (http://projects.theforeman.org/issues/3218 has background).

I would suggest "Deploy on" is either disabled temporarily while host group is reloading, or we're careful to keep the user's deploy on selection when the form is reloaded.

Comment 3 Dominic Cleal 2014-06-11 15:44:49 UTC
Created redmine issue http://projects.theforeman.org/issues/6167 from this bug

Comment 4 Bryan Kearney 2015-08-25 17:24:12 UTC
Upstream bug component is Hosts

Comment 5 Bryan Kearney 2016-04-14 14:08:27 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6167 has been closed
-------------
Ondřej Pražák
Applied in changeset commit:f9f8b02563173d24e4f19f2f42ddff1c5ed1722a.

Comment 6 Kedar Bidarkar 2016-05-11 17:20:53 UTC
'Deployed on' dropdown in hosts/new form disabled until ajax on hostgroup_changed is resolved


VERIFIED With sat62-snap10.1

Comment 7 Bryan Kearney 2016-07-27 11:38:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.