Bug 110834 - redhat-config-packages lacks documentation
redhat-config-packages lacks documentation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 13:59 EST by Dalibor Topic
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dalibor Topic 2003-11-24 13:59:20 EST
Description of problem:

There is no man page or GNU info documentation for
redhat-config-packages. The only documentation one can get is the very
non-descriptive output of redhat-config-packages --help.
Comment 1 Hacksaw 2003-12-18 02:43:48 EST
R-C-P is altogether incomprehensible. It's certainly pretty.

What does a check mark mean, that the package is going to be
installed, or already is?

If it means already installed, why does it not show openoffice.org on
my box. I installed the rpm's by hand. And why then does it start by
offering to install almost 3 gigs of extra stuff?

What I would like to see is this: The list shows me a list of all
possible packages, which should include that which is on the disc's
plus any additional repositories I supply.

The list should have an "I" in front of any package already installed,
and a blank box in front of any not installed. If the user selects a
not installed package, it changes to a checkmark and the name of the
package should get bold. If they select an installed package, it
should change to an X and the name of the package should get greyed
out a little.

Nothing should be selected by default.

This would go a long way towards making it obvious what is going on,
and make the need for extra documentation less.
Comment 2 Jeremy Katz 2005-09-21 16:21:48 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.