Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1108340

Summary: Allow the CLI to return more than 50 results
Product: Red Hat Enterprise Linux 7 Reporter: Dave Sullivan <dsulliva>
Component: redhat-support-toolAssignee: Keith Robertson <kroberts>
Status: CLOSED ERRATA QA Contact: Filip Holec <fholec>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.1CC: dsulliva, fholec, jmoran, mhuth, psplicha
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-05 13:31:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Dave Sullivan 2014-06-11 18:39:07 UTC
Description of problem:

The shell allows you to get access to more results from a search, by entering m.

However the straight CLI does not, you get 50 and it dumps out.

If I'm doing proactive queries on subject I want to get the full set so I automate scripts to proactively check for new kcs/issues to review.  With having a limit return I can't do that.

This is command problem with cli tools that interface with backends.

e.g.
There appears to be a limitation on results returned with the ipa cli can this be modified
https://access.redhat.com/site/solutions/261023

In the example above there's db/slapd limit and a client cli limit and a timelimit.  

This ensures that from cli you can get a many results as possible up to the limit of Strata max.

Then it can be on the user to see if they are hitting that max to determine whether fine tuning their query is required.

[dsulliva@localhost ~]$ redhat-support-tool search "kdump" | grep Title | wc -l
50

[dsulliva@localhost ~]$ redhat-support-tool search "kdump"
Title:   Kdump cannot start when booting the system which error is kdump: mkdumprd: failed to make kdump initrd
ID:      180113                                                      
State:   Unverified: This solution has not yet been verified to work by Red Hat customers.
URL:     https://access.redhat.com/site/solutions/180113             

...

 50 [ 392443:VER] Kdump wrongfully states that the crashkernel parameter is not specified - RHEL 5
 51 [  47111:UNV] kdump kernel hangs during bringing up bnx2x interface
 52 [  62354:VER] kdump warning to increase reserved memory
 53 [ 198343:VER] I blacklisted a module in /etc/kdump.conf, why is it still loaded in the kdump environment?
 54 [ 267023:VER] Start of kdump Fails with " Could not find a free area of memory of 5f3001 bytes... ELF exec load failed"
 55 [  56051:VER] What is the use of "default" parameter in kdump.conf file ?
 56 [  47470:VER] How am I aware vmcore is created by kdump.
 57 [  47346:UNV] kdump rebooted or dropped into shell before saving vmcore
 58 [  43316:VER] Enabling kdump on RHEL 6 gives the error : "Memory for crashkernel is not reserved"
 59 [ 237303:VER] [RHEL5] Kdump Hangs on CCISS Module.
59 of 100 solutions displayed. Type 'm' to see more, 'r' to start from the beginning again, or '?' for help with the codes displayed in the above output.
Select a Solution:



Version-Release number of selected component (if applicable):

latest version


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

It would be nice to document the Strata max result return as well

Comment 7 Dave Sullivan 2014-09-24 21:14:27 UTC
Hi Mark,

Sorry was out on leave, I'll try this out tomorrow.

Thanks,

Dave

Comment 12 errata-xmlrpc 2015-03-05 13:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0574.html