Bug 110835 - redhat-config-packages requires a lot of disc juggling
Summary: redhat-config-packages requires a lot of disc juggling
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-packages   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 19:08 UTC by Dalibor Topic
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 20:20:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dalibor Topic 2003-11-24 19:08:55 UTC
Description of problem:
Using redhat-config-packages to install GNOME after a custom
installation requires a lot of disc-juggling between discs 1 and 2. It
would be nice if redhat-config-packages would be able to first install
the packages off one cd, then off the other. 

(This only works if you fix the bug in redhat-config-packages to
prevent it from always breaking because it looks for RPMs in a
non-existing directory.)

Version-Release number of selected component (if applicable):


How reproducible:
Easily: Install Fedora Core 1 with a custom install where you don;t
have GNOME selected. Login as root, startx, fix the
redhat-config-packages CD directory bug by changing a RedHat/RPMS in
methods.py into Fedora/RPMS, run redhat-config-packages, select GNOME,
and juggle discs like fat boy slim.

Comment 1 Nick Lamb 2003-11-24 21:59:28 UTC
This would require the use of a temporary package cache as far as I
can tell, here's why...

Say you want to install foo-1.2 which depends on bar-3.0 and baz-0.96,
and baz-0.96 itself depends on quux-1.0.2

baz-0.96 is on CD 2, the rest are on CD 1

RPM cannot install baz until quux has been installed, because it
cannot tell whether merely _installing_ baz would require quux (e.g.
for a script to be run). So it asks for CD1 to install quux-1.0.2, and
perhaps installs bar-3.0 but it can't install foo-1.2 yet because it
needs baz-0.9 which is on CD2. So now it asks for CD2, then installs
baz-0.96. Finally it can install foo, but it needs CD1 back to do so.

You can imagine that this is much worse when the number of packages
increases.

The best way to resolve this is with a cache of RPM files on local
storage, perhaps in /var/somewhere. Then redhat-config-packages can
see whether packages are needed from more than one CD, and if so copy
them to /var/somewhere one CD at a time, then install the whole lot in
its preferred order.

However that increases the disk space requirement for a new package
install when using redhat-config-packages. So it would probably have
to be optional. This increases the complexity yet again.

Comment 2 Paul Pluzhnikov 2004-11-11 22:14:32 UTC
The same problem exists on FC3 -- install without GNOME development,
then add it later -- 30 packages are selected, and require swapping of
disks 1, 2 and 3 a total of 14 times!

Nick> The best way to resolve this is with a cache of RPM ...

The problem here is that the packages are scattered over CDs without
apparent consideration of interdependencies (how is package placement
on CDs decided now?)

If packages were split over CDs such that packages on CD1 depend only
on other packages on CD1; packages on CD2 depend only on other
packages on CD{1,2}; etc. then all packages could be installed in a
single pass. 

Comment 3 Paul Pluzhnikov 2004-11-11 22:29:29 UTC
Also,

Nick> However that increases the disk space requirement ...

That's true, but if there is 7 GBytes of free space in /var/tmp and
you are installing 50 MBytes worth of packages, surely they can be cashed?


Comment 4 Ross Porter 2004-12-16 17:00:41 UTC
Maybe it's just me but why can Anaconda install from one disk and then
the next and the next in order without juggling?  Seems to me that a
little code from Anaconda simply needs inserted in
redhat-config-packages.  And why would a cache of the packages on the
disk take any more space?  You need space to have them installed in
the first place.  As the individual packages get installed they would
get deleted from the cache taking so little extra space for such a
short time that if you have any reasonable amount of free space on
your partitions, it shouldn't be a problem.

Also, get the DVD version of FC if you can.  Correct me if I'm wrong
but last I heard that version doesn't have this problem.

Comment 5 Jeremy Katz 2005-09-21 20:20:36 UTC
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.


Note You need to log in before you can comment on or make changes to this bug.