Bug 110838 - redhat-config-network does not create the proper links for copied interfaces in /etc/sysconfig/network-scripts when changing profiles
redhat-config-network does not create the proper links for copied interfaces ...
Status: CLOSED DUPLICATE of bug 85651
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-profiling
  Show dependency treegraph
 
Reported: 2003-11-24 14:22 EST by Keith T. Garner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 09:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith T. Garner 2003-11-24 14:22:00 EST
Description of problem:
redhat-config-network does not create the proper links for copied
interfaces in /etc/sysconfig/network-scripts when changing profiles.

Version-Release number of selected component (if applicable):
redhat-config-network-tui-1.3.10-1
redhat-config-network-1.3.10-1


How reproducible:
Everytime

Steps to Reproduce:
1. Create two hardware devices in redhat-config-network.  Say eth0 a
wired card, and eth1 a wireless card.
2. Configure eth0 to be included in the Common profile
3. Make two copies of eth1: eth1_home, eth1_work
4. Create a profile called home and activate eth1_home in home
5. Create a profile called work and activate eth1_work in work
6. Set your profile to home.

  
Actual results:
/etc/sysconfig/network-scripts/ifcfg-eth1_home is created

Expected results:
/etc/sysconfig/network-scripts/ifcfg-eth1 is created

Additional info:
This profile scheme worked as documented in RH9.
Comment 1 Harald Hoyer 2003-11-25 04:00:28 EST
This is intented, as the new initscripts should handle
# /sbin/ifup eth1_home
as well.
Comment 2 Keith T. Garner 2003-11-25 10:59:10 EST
While one can do that, about about auto ifuped devices like a pcmcia
network card?  When one pops in a card, it'll show up as eth1 to the
system, and the pcmcia scripts will attempt to "ifup eth1" which will
not exist.

While I can manually ifup the device, I do believe this change breaks
expected funtionality.
Comment 3 Harald Hoyer 2005-09-16 09:45:44 EDT

*** This bug has been marked as a duplicate of 85651 ***

Note You need to log in before you can comment on or make changes to this bug.