Bug 1108384 - cron daemon fails to log that it is shutting down.
Summary: cron daemon fails to log that it is shutting down.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-11 22:08 UTC by Evan Rempel
Modified: 2015-05-20 15:15 UTC (History)
4 users (show)

Fixed In Version: cronie-1.4.4-14.el6
Doc Type: Enhancement
Doc Text:
The crond daemon now logs shutdowns. Its proper terminations are therefore distinguishable from abnormal ones.
Clone Of:
: 1207096 (view as bug list)
Environment:
Last Closed: 2015-03-19 12:31:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0704 normal SHIPPED_LIVE cronie bug fix and enhancement update 2015-03-19 16:26:29 UTC

Description Evan Rempel 2014-06-11 22:08:32 UTC
Description of problem:

The cron daemon fails to log that it is shutting down.


Version-Release number of selected component (if applicable):

All Redhat 6 platforms

How reproducible:

Steps to Reproduce:
1. /sbin/service crond stop
2. review the syslog

Actual results:

Nothing in the syslog regarding the shutdown.

Expected results:

A log line similar to the startup line should be logged.

2014-06-11T15:05:52-07:00 local@catamount.comp.uvic.ca cron.info crond[25689]: (CRON) STARTUP (1.4.4)


Additional info:

This problem also exists in Redhat 5.

2014-06-11T15:07:54-07:00 local@gecko.comp.uvic.ca cron.info crond[13998]: (CRON) STARTUP (V5.0)

Comment 2 Marcela Mašláňová 2014-09-04 11:43:56 UTC
How would log of stopping the daemon helped? Children of crond will be executed anyway if they already started. I don't think it's a good feature, because it won't tell you if jobs were executed or not. Tracking jobs is different issue, but I wouldn't do from cron something more complicated than it is.

Comment 3 Evan Rempel 2014-09-04 21:49:25 UTC
The issue arises when attempting to monitor activity on a system and feed the logs into a SIEM or other reporting engine. Stopping of the crond process used to log that it was stopping, but no longer does.

Nearly all daemons log when they start and when they stop. crond should do the same.

2014-09-04 14:47:28 localhostcron.info crond[27874]: (CRON) STARTUP (V5.0)

crond logs when it starts, and it should log when it stops.

Comment 4 Tomas Mraz 2014-09-16 14:00:28 UTC
To help to prioritize the issue please report it through the regular Red Hat support channels.

http://www.redhat.com/support

Comment 8 errata-xmlrpc 2015-03-19 12:31:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0704.html


Note You need to log in before you can comment on or make changes to this bug.