Bug 11085 - Receive 'Bad file descriptor' after automatic partitioning
Receive 'Bad file descriptor' after automatic partitioning
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-27 22:08 EDT by fairwindsii
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 13:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fairwindsii 2000-04-27 22:08:01 EDT
I tried the following procedure with the original 6.2 CD and with the last
update and boot disk.

If I choose these options:
Language selection: English
Keyboard selection: US
RedHat Linux: OK
Installation Type: Install GNOME Workstation
Automatic Partitioning: Continue
Low Memory: Yes
Hostname Configuration: Back
Low Memory: Yes

At this time, I receive this error:
Exception Occurred

Traceback (innermost last):
  File "/usr/bin/anaconda", line 342, in ?
    intf.run(todo, test = test)
  File "/usr/lib/anaconda/text.py", lime 1165, in run
    rc = apply (step[1](), step[2])
  File "/usr/lib/anaconda/textw/partitioning.py", line 199, in __call__
    todo.fstab.savePartition ()
  File "/usr/lib/anaconda/fstab.py", line 149, in savePartitions
    self.ddruid.save()
  SystemError: Error partitioning drive /tmp/hda: Bad file descriptor
Comment 1 Jay Turner 2000-04-28 09:01:59 EDT
I have replicated this in the test lab.  As a workaround, try to avoid going
back to this "low memory" screen.  This is the point in the installer where the
swap partition is initialized, and going back and forth through that section of
code can definitely lead to problems.
Comment 2 Michael Fulbright 2000-11-13 16:24:06 EST
Passed to QA to verify against 7.0.
Comment 3 Brock Organ 2000-11-14 10:54:05 EST
The bug reporting is better in 7.0 (instead of a traceback, a dialog informing
you that you need to reboot is displayed), but the issue is still not properly
handled ... so I am leaving the issue open

(ie. If you cycle through the "turn swap on" dialog multiple times, the install
should not fail ...)
Comment 4 Erik Troan 2001-01-16 13:31:55 EST
Forcing you to reboot is the correct behavior. Once you turn on swap, we can't
rewrite the partition tables.

Note You need to log in before you can comment on or make changes to this bug.