Bug 110855 - download tree hierarch
download tree hierarch
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 16:42 EST by David Farning
Modified: 2014-03-16 22:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 16:33:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Farning 2003-11-24 16:42:01 EST
Description of problem:

Version-Release number of selected component (if applicable):
all

How reproducible:
n/a

The download tree is starting to deviate from the standard.

The root level will contain the overall package sets.
[core|extras|alternatives|3rd party|...]

Each of these package sets will contain subsets of packages in
differentstates of development.  The numbered release will freeze
atapproximately 2-3 month intervals.  Development and Testing are
rollingreleases.
[1|2|...|development|test]

Each of these Releases may be compiled for a number of archs. 
[i386|i386_64|...]

Additionally, the numbered release will have updates and possibly
legacypackages.  Updates will continue for approximately 12 months and
thelegacy will continue as long as maintainers are interested.
[updates|legacy]
This should result in a tree looking as such.fedora
  -core
    -1
      -i386
      -i86_64
      -updates
        -i386
      -legacy
        -i386
     -2
      -i386
      -i86_64
    -development
      -i386
      -i386_64
    -test
       -i386
  -extras
    -1
      -i386
    -2
      -i386

There is already some deviance from this tree with
  -core
    -updates
      -1
      -testing

Because each numbered release will contain updates, updates should be
achild of it's numbered parent.  -updates/test either needs to merge
into-test or -1/updates.
Comment 1 Bill Nottingham 2004-09-13 14:44:42 EDT
Which standard are you refering to?
Comment 2 Bill Nottingham 2005-03-02 16:33:21 EST
Closing, we're not going to change the heirarchy at this point. Maybe the docs... :)

Note You need to log in before you can comment on or make changes to this bug.