Bug 1108642 - Spice session freezes randomly
Summary: Spice session freezes randomly
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-12 11:18 UTC by Marc-Andre Lureau
Modified: 2014-10-14 06:47 UTC (History)
5 users (show)

(edit)
Previously, various clipboard managers, operating on the client or on the guest, would occasionally lose synchronization, which resulted in clipboard data loss and the SPICE console freezing. Now, spice-gtk have been patched, such that clipboard synchronization does not freeze the SPICE console anymore.
Clone Of:
(edit)
Last Closed: 2014-10-14 06:47:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1487 normal SHIPPED_LIVE spice-gtk bug fix and enhancement update 2014-10-14 01:28:31 UTC

Description Marc-Andre Lureau 2014-06-12 11:18:06 UTC
This is the same bug as RHEVM bug 1083489.

commit 4eb0d20f0ad3f5219385e5b78cf2bc67b247e11e

    clipboard: check that clipboard request does not belong to remote

    Check clipboard owner, to avoid cyclic dependency of clipboard requests.

Comment 1 Marc-Andre Lureau 2014-06-12 14:04:30 UTC
ready, waiting for qa ack

Comment 4 Marc-Andre Lureau 2014-07-22 09:57:21 UTC
*** Bug 1073364 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2014-10-14 06:47:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html


Note You need to log in before you can comment on or make changes to this bug.