Bug 1108758 - Broken dependencies on uglify-js
Summary: Broken dependencies on uglify-js
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-transformers
Version: el6
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jamie Nguyen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-12 14:04 UTC by Tomas Smetana
Modified: 2014-07-22 18:09 UTC (History)
3 users (show)

Fixed In Version: nodejs-transformers-3.0.0-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-12 02:21:58 UTC


Attachments (Terms of Use)

Description Tomas Smetana 2014-06-12 14:04:50 UTC
Description of problem:
The nodejs-transformers package cannot be installled due to broken dependencies.

Version-Release number of selected component (if applicable):
nodejs-transformers-3.0.0-3.el6

How reproducible:
Always

Steps to Reproduce:
1. yum install nodejs-transformers

Actual results:
Error: Package: nodejs-transformers-3.0.0-3.el6.noarch (epel)
           Requires: npm(uglify-js) < 2.3
           Installing: uglify-js-2.4.13-5.el6.noarch (epel)
               npm(uglify-js) = 2.4.13
Error: Package: nodejs-transformers-3.0.0-3.el6.noarch (epel)
           Requires: npm(uglify-js) < 2.3
           Available: uglify-js-2.4.13-5.el6.noarch (epel)
               npm(uglify-js) = 2.4.13

Expected results:
The package is installed.

Comment 1 Jamie Nguyen 2014-06-29 17:36:38 UTC
Thanks for the bug report.

Sorry about this. Updates to follow.

Comment 2 Fedora Update System 2014-06-29 17:39:05 UTC
nodejs-transformers-3.0.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nodejs-transformers-3.0.0-5.fc20

Comment 3 Fedora Update System 2014-06-29 17:39:19 UTC
nodejs-transformers-3.0.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nodejs-transformers-3.0.0-5.fc19

Comment 4 Fedora Update System 2014-06-29 17:39:34 UTC
nodejs-transformers-3.0.0-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-transformers-3.0.0-5.el6

Comment 5 Fedora Update System 2014-06-30 03:36:57 UTC
Package nodejs-transformers-3.0.0-5.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nodejs-transformers-3.0.0-5.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1776/nodejs-transformers-3.0.0-5.el6
then log in and leave karma (feedback).

Comment 6 lnie 2014-07-01 06:23:47 UTC
nodejs-transformers-3.0.0-5.fc20 works

Comment 7 Fedora Update System 2014-07-12 02:21:58 UTC
nodejs-transformers-3.0.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-07-12 02:23:47 UTC
nodejs-transformers-3.0.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-07-22 18:09:35 UTC
nodejs-transformers-3.0.0-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.