Bug 110893 - "Redirect" changes date on message being redirected
Summary: "Redirect" changes date on message being redirected
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-25 11:02 UTC by chris
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 17:02:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream patch against evolution-2.8.0-7.fc6.src (3.42 KB, patch)
2007-01-06 00:21 UTC, Baris Cicek
no flags Details | Diff

Description chris 2003-11-25 11:02:34 UTC
When using the "Redirect" command on the "Actions" -> "Forward" menu,
Evolution changes the date on the redirected message to be the current
date and time.

This is really confusing, since the original From:/To:/Cc:/etc.
headers remain unchanged (as they should) - it makes it look as if the
original sender sent the message at the time when the redirect happened.

Surely the Date: header should also remain unchanged when redirecting?

Comment 1 chris 2004-11-18 14:23:06 UTC
Still doing this in FC3, evolution-2.0.2-3 - "Date:" header being
changed instead of adding a "Resent-Date:" header.

Comment 2 chris 2005-10-14 17:51:32 UTC
Still doing it in FC4, evolution-2.2.3-2.fc4

Comment 3 chris 2006-11-04 15:52:06 UTC
I'm guessing that after nearly 3 years this just ain't gonna be fixed.  But, for
what it's worth, it's still doing it in FC6, evolution-2.8.1.1-3.fc6...

Comment 4 Baris Cicek 2007-01-06 00:21:57 UTC
Created attachment 144948 [details]
Upstream patch against evolution-2.8.0-7.fc6.src

Here's the upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=393336

This patch fixes this longly survived problem.

Comment 5 Dave Malcolm 2007-01-08 13:26:59 UTC
Thanks for reporting this, and for supplying the patch. 

I'm sorry this went for so long without attention; for some reason the bug was
still assigned to me and not mbarnes.

Reassigning to mbarnes; once again, my apologies for not handling this sooner.

Comment 6 Matthew Barnes 2007-01-09 17:02:07 UTC
Closing as UPSTREAM since this was recently moved upstream.

I will continue to track the problem there.


Note You need to log in before you can comment on or make changes to this bug.