Bug 1108944 - SAM 1.4 doesn't provide channel-mapping data for RHEL7 channels
Summary: SAM 1.4 doesn't provide channel-mapping data for RHEL7 channels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-06-12 23:27 UTC by Rich Jerrido
Modified: 2014-10-14 07:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Rich Jerrido 2014-06-12 23:27:11 UTC
Description of problem:

When SAM1.4 is connected to a Satellite 5.6 instance via spacewalk-splice-checkin, clients using RHEL7 channels (such as rhel-x86_64-server-7) aren't properly detected. 

Version-Release number of selected component (if applicable):
SAM 1.4 & subscription-manager-migration-data-2.0.5-1.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. Install SAM 1.4 with enhanced reporting as per the docs [1]
2. Install / configure guests using RHEL7 channels. 
3. run spacewalk-splice-checkin to refresh SAM with data from the newly installed guests. 

Actual results:

Systems show in SAM as having a valid subscription and no subscription is attached.  


Expected results:
Systems show in SAM as requiring a subscription for RHEL, until a subscription is (auto)attached. 



Additional info:

This behavior is occurring due to the lack of a mapping for RHEL7 channels in 
/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt. As a workaround, mappings can be administratively added such as 

rhel-x86_64-server-7: Server-Server-x86_64-06e8bd9df3f0-69.pem

to map RHEL7 to product 69: Red Hat Enterprise Linux Server. 


[1] - https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/5.6/html-single/Installation_Guide/index.html#sect-Installation_Guide-Entitlements-Enhanced_Entitlements_Reporting

Comment 1 Chris Duryee 2014-06-16 13:01:05 UTC
Moving component to subscription-manager-migration-data, which needs to be updated for the latest mappings.

Comment 4 John Sefler 2014-08-29 20:17:51 UTC
Verifying Version...

[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.12-1.el6.noarch

[root@jsefler-6 ~]# egrep rhel-.*-server-7 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-ppc64-server-7: Server-ppc64-e1cbd26082ac-74.pem
rhel-ppc64-server-7-beta-debuginfo: Server-ppc64-e1cbd26082ac-74.pem
rhel-ppc64-server-7-debuginfo: Server-ppc64-e1cbd26082ac-74.pem
rhel-s390x-server-7: Server-s390x-33a3fea9ee7e-72.pem
rhel-s390x-server-7-beta-debuginfo: Server-s390x-33a3fea9ee7e-72.pem
rhel-s390x-server-7-debuginfo: Server-s390x-33a3fea9ee7e-72.pem
rhel-x86_64-server-7: Server-x86_64-f2915f6444f4-69.pem
rhel-x86_64-server-7-beta-debuginfo: Server-x86_64-f2915f6444f4-69.pem
rhel-x86_64-server-7-debuginfo: Server-x86_64-f2915f6444f4-69.pem
rhel-x86_64-server-7-mrg-messaging-2: mrg-m-2-rhel-7-x86_64-f31eda39749d-260.pem
rhel-x86_64-server-7-mrg-messaging-2-debuginfo: mrg-m-2-rhel-7-x86_64-f31eda39749d-260.pem
rhel-x86_64-server-7-ost-5: OpenStack-5.0-x86_64-4dbb67de7a84-191.pem
rhel-x86_64-server-7-ost-5-cts: OpenStack-5.0-CTS-x86_64-fe7f145d82b8-208.pem
rhel-x86_64-server-7-ost-5-cts-debuginfo: OpenStack-5.0-CTS-x86_64-fe7f145d82b8-208.pem
rhel-x86_64-server-7-ost-5-debuginfo: OpenStack-5.0-x86_64-4dbb67de7a84-191.pem
rhel-x86_64-server-7-rhscl-1: Server-RHSCL-x86_64-92ff64b217d0-201.pem
rhel-x86_64-server-7-rhscl-1-debuginfo: Server-RHSCL-x86_64-92ff64b217d0-201.pem
rhel-x86_64-server-7-thirdparty-oracle-java: Server-x86_64-595f673ff23c-240.pem
rhn-tools-rhel-ppc64-server-7: Server-ppc64-e1cbd26082ac-74.pem
rhn-tools-rhel-ppc64-server-7-beta-debuginfo: Server-ppc64-e1cbd26082ac-74.pem
rhn-tools-rhel-ppc64-server-7-debuginfo: Server-ppc64-e1cbd26082ac-74.pem
rhn-tools-rhel-s390x-server-7: Server-s390x-33a3fea9ee7e-72.pem
rhn-tools-rhel-s390x-server-7-beta-debuginfo: Server-s390x-33a3fea9ee7e-72.pem
rhn-tools-rhel-s390x-server-7-debuginfo: Server-s390x-33a3fea9ee7e-72.pem
rhn-tools-rhel-x86_64-server-7: Server-x86_64-f2915f6444f4-69.pem
rhn-tools-rhel-x86_64-server-7-beta-debuginfo: Server-x86_64-f2915f6444f4-69.pem
rhn-tools-rhel-x86_64-server-7-debuginfo: Server-x86_64-f2915f6444f4-69.pem
[root@jsefler-6 ~]# 


VERIFIED: Lots of RHEL7 channels are now mapped to product certs in subscription-manager-migration-data-2.0.12-1.
I am not familiar with the SAM/Satellite configuration in comment 0, but it sounds like this version of subscription-manager-migration-data package will work for you.  If not, please re-open.

Comment 5 errata-xmlrpc 2014-10-14 07:47:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.