Bug 1108952 - OutOfMemoryError with large patches
OutOfMemoryError with large patches
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER9
: EAP 6.3.0
Assigned To: Emanuel Muckenhuber
Jan Martiska
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-12 20:29 EDT by James Livingston
Modified: 2016-02-21 19:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In Previous versions of JBoss EAP 6, attachment data passed from master to slave host controllers was read fully into memory. As a consequence, when installing large patches, an `OutOfMemoryError` may occur on child host controllers. This could occur when installing CP04 via the domain controller with the default memory settings. In this release of the product, attachments are saved to temporary files, so as to not consume excessive memory and `OutOfMemoryErrors` do not occur on child host controllers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 10:38:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-3359 Major Resolved Transferring an operation attachments to slaves may lead to an OOM 2017-07-10 22:18 EDT
Red Hat Knowledge Base (Solution) 949923 None None None Never

  None (edit)
Description James Livingston 2014-06-12 20:29:29 EDT
Due to WFLY-3359 you can run out of heap space on slave HCs when installing large patches from the DC. A patch slightly over 128mb will temporarily need 384mb of space as the backing byte array is resized, likely causing an OOME with the default -Xmx512m setting.
Comment 4 Emanuel Muckenhuber 2014-06-13 07:53:56 EDT
Maybe this should be ported back to 6.2.x though? I don't recall if that happened.
Comment 5 James Livingston 2014-06-15 18:26:48 EDT
It's not in 6.2.x currently
Comment 8 Martin Simka 2014-07-03 08:20:36 EDT
verified on EAP 6.3.0.ER8 but not during ER8 test cycle. BZ was moved to ON_QA after ER8 test cycle ended.

Note You need to log in before you can comment on or make changes to this bug.