Bug 1109027 - [virtio-win][netkvm]Name field is empty when using netsh command
Summary: [virtio-win][netkvm]Name field is empty when using netsh command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-13 05:50 UTC by Mike Cao
Modified: 2015-11-26 12:24 UTC (History)
8 users (show)

Fixed In Version: virtio-win-prewhql-0.1-87
Doc Type: Bug Fix
Doc Text:
Using the "netsh" command now properly displays device names regardless of the number of network devices plugged in to the system.
Clone Of:
Environment:
Last Closed: 2015-11-24 08:41:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Mike Cao 2014-06-13 05:50:17 UTC
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-86

How reproducible:
100%

Steps to Reproduce:
1.install win7-64 bit guest w/ virtio-net-pci
2.rundll32 netkvmco.dll,RegisterNetKVMNetShHelper in the guest
3.netsh netkvm show devices

Actual results:
Name :   

Expected results:
Name : <Adatper Name should be displayed here>

Additional info:

Comment 8 Mike Cao 2014-07-08 05:33:14 UTC
Fixed in virtio-win-prewhql-0.1-87

Comment 9 Mike Cao 2014-07-08 06:41:23 UTC
Reproduce this issue on virtio-win-prewhql-86
Verified this issue on virtio-win-prewhql-87 

Steps same as comment #0

Actual Results:
The value of name is not empty

Comment 10 Mike Cao 2014-07-08 06:47:59 UTC
But in virtio-win-prewhql-87 ,the output of Description&name in ipconfig and netsh are not same 

ipconfig /all 
Windows IP Configuration

   Host Name . . . . . . . . . . . . : 087NICWIN764COK
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : nay.redhat.com

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : nay.redhat.com
   Description . . . . . . . . . . . : Red Hat VirtIO Ethernet Adapter #2
   Physical Address. . . . . . . . . : 00-52-21-12-D9-9E
   DHCP Enabled. . . . . . . . . . . : Yes

Ethernet adapter SupportDevice0:

   Connection-specific DNS Suffix  . : nay.redhat.com
   Description . . . . . . . . . . . : Red Hat VirtIO Ethernet Adapter
   Physical Address. . . . . . . . . : 00-52-2A-12-D9-9E
   DHCP Enabled. . . . . . . . . . . : Yes

Ethernet adapter MessageDevice:

   Connection-specific DNS Suffix  . : nay.redhat.com
   Description . . . . . . . . . . . : Realtek RTL8139C+ Fast Ethernet NIC
   Physical Address. . . . . . . . . : 00-52-12-5B-B0-F2
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::80dd:59be:fcf4:d1e7%11(Preferred)

#netsh netkvm show devices
NetKVM device: PCI\VEN_10EC&DEV_8139&SUBSYS_11001AF4&REV_20\3&13C0B0C5&0&18
Index	: 0
Description	: Realtek RTL8139C+ Fast Ethernet NIC
Name	: Realtek RTL8139C+ Fast Ethernet NIC
Location	: PCI bus 0, device 3, function 0
Number on bus	: 3
Software registry key	: SYSTEM\ControlSet001\Control\CLASS\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007

NetKVM device: PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&0&20
Index	: 1
Description	: Red Hat VirtIO Ethernet Adapter
Name	: Red Hat VirtIO Ethernet Adapter
Location	: PCI bus 0, device 4, function 0
Number on bus	: 4
Software registry key	: SYSTEM\ControlSet001\Control\CLASS\{4D36E972-E325-11CE-BFC1-08002BE10318}\0012

NetKVM device: PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&0&28
Index	: 2
Description	: Red Hat VirtIO Ethernet Adapter
Name	: Red Hat VirtIO Ethernet Adapter #2
Location	: PCI bus 0, device 5, function 0
Number on bus	: 5
Software registry key	: SYSTEM\ControlSet001\Control\CLASS\{4D36E972-E325-11CE-BFC1-08002BE10318}\0014


Yan ,Is it an new bug ?

Comment 11 Yan Vugenfirer 2014-07-20 16:07:11 UTC
Hi Mike,

"Name" in netsh is the "description" in ipconfig.

The important thing that there is a "#" and a number when we have multiple devices.

Best regards,
Yan.

Comment 12 Mike Cao 2014-07-21 02:33:22 UTC
Based on comment #10&comment #11 ,this issue has been fixed ald 

Move status to Verified

Comment 19 lijin 2015-05-14 07:08:30 UTC
test with virtio-win-1.7.4-1.el6_6.noarch on win7-32 guest.
boot guest with one virtio-net-pci,name field is still empty when using netsh command;
boot guest with three virtio-net-pci,only the first netkvm name field is empty,names of the other two are shown correctly.

So re-assign this bug.

package info:
    virtio-win-1.7.4-1.el6_6.noarch
    kernel-2.6.32-555.el6.x86_64
    qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
    seabios-0.6.1.2-30.el6.x86_64
    spice-server-0.12.4-12.el6.x86_64

Comment 20 lijin 2015-05-14 07:12:17 UTC
(In reply to lijin from comment #19)
> test with virtio-win-1.7.4-1.el6_6.noarch on win7-32 guest.
> boot guest with one virtio-net-pci,name field is still empty when using
> netsh command;
> boot guest with three virtio-net-pci,only the first netkvm name field is
> empty,names of the other two are shown correctly.
> 
> So re-assign this bug.
> 
> package info:
>     virtio-win-1.7.4-1.el6_6.noarch
>     kernel-2.6.32-555.el6.x86_64
>     qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
>     seabios-0.6.1.2-30.el6.x86_64
>     spice-server-0.12.4-12.el6.x86_64

can reproduce this issue with virtio-win-1.7.2-2.el6

Comment 21 Mike Cao 2015-05-14 07:15:16 UTC
(In reply to lijin from comment #20)
> (In reply to lijin from comment #19)
> > test with virtio-win-1.7.4-1.el6_6.noarch on win7-32 guest.
> > boot guest with one virtio-net-pci,name field is still empty when using
> > netsh command;
> > boot guest with three virtio-net-pci,only the first netkvm name field is
> > empty,names of the other two are shown correctly.
> > 
> > So re-assign this bug.
> > 
> > package info:
> >     virtio-win-1.7.4-1.el6_6.noarch
> >     kernel-2.6.32-555.el6.x86_64
> >     qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
> >     seabios-0.6.1.2-30.el6.x86_64
> >     spice-server-0.12.4-12.el6.x86_64
> 
> can reproduce this issue with virtio-win-1.7.2-2.el6

The patches has been included in virtio-win-prewhql-87 . which is not including in virtio-win-prewhql-98 build ,Can you retest w/ virtio-win-prewhql 87 or virtio-win-prewhql-103 ?

Comment 22 lijin 2015-05-14 07:21:50 UTC
(In reply to Mike Cao from comment #21)
> (In reply to lijin from comment #20)
> > (In reply to lijin from comment #19)
> > > test with virtio-win-1.7.4-1.el6_6.noarch on win7-32 guest.
> > > boot guest with one virtio-net-pci,name field is still empty when using
> > > netsh command;
> > > boot guest with three virtio-net-pci,only the first netkvm name field is
> > > empty,names of the other two are shown correctly.
> > > 
> > > So re-assign this bug.
> > > 
> > > package info:
> > >     virtio-win-1.7.4-1.el6_6.noarch
> > >     kernel-2.6.32-555.el6.x86_64
> > >     qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
> > >     seabios-0.6.1.2-30.el6.x86_64
> > >     spice-server-0.12.4-12.el6.x86_64
> > 
> > can reproduce this issue with virtio-win-1.7.2-2.el6
> 
> The patches has been included in virtio-win-prewhql-87 . which is not
> including in virtio-win-prewhql-98 build ,Can you retest w/
> virtio-win-prewhql 87 or virtio-win-prewhql-103 ?

build87 works fine.
feel free to modify the status.

Comment 23 Mike Cao 2015-05-14 07:24:27 UTC
(In reply to lijin from comment #22)
> (In reply to Mike Cao from comment #21)
> > (In reply to lijin from comment #20)
> > > (In reply to lijin from comment #19)
> > > > test with virtio-win-1.7.4-1.el6_6.noarch on win7-32 guest.
> > > > boot guest with one virtio-net-pci,name field is still empty when using
> > > > netsh command;
> > > > boot guest with three virtio-net-pci,only the first netkvm name field is
> > > > empty,names of the other two are shown correctly.
> > > > 
> > > > So re-assign this bug.
> > > > 
> > > > package info:
> > > >     virtio-win-1.7.4-1.el6_6.noarch
> > > >     kernel-2.6.32-555.el6.x86_64
> > > >     qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
> > > >     seabios-0.6.1.2-30.el6.x86_64
> > > >     spice-server-0.12.4-12.el6.x86_64
> > > 
> > > can reproduce this issue with virtio-win-1.7.2-2.el6
> > 
> > The patches has been included in virtio-win-prewhql-87 . which is not
> > including in virtio-win-prewhql-98 build ,Can you retest w/
> > virtio-win-prewhql 87 or virtio-win-prewhql-103 ?
> 
> build87 works fine.
> feel free to modify the status.
pls retest w/ virtio-win-prewhql-103

Comment 24 lijin 2015-05-14 07:51:32 UTC
build103 also works well

Comment 27 errata-xmlrpc 2015-11-24 08:41:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.