Bug 110908 - network profiles break when upgrading from RedHat 9
network profiles break when upgrading from RedHat 9
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 09:44 EST by Andy Grimm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 00:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2003-11-25 09:44:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I have upgraded two laptops from RedHat 9 to Fedora Core 1, and in
both cases there were issues with network profiles after the upgrade.
 I have grub configurations specifying parameters such as
"netprofile=Work" or "netprofile=Home", and for whatever reason, the
network start-up was loading multiple profiles.  For example, it would
load the "Home" configuration, but then also load the "Work"
configuration.  the result was that the IP would be determined by the
last one loaded.  Also, there would be multiple hard links in
/etc/sysconfig/network-scripts  ... ifcfg_eth0_work and
ifcfg_eth0_home.  I eventually fixed my profiles by hand, editing
/etc/sysconfig/networking/profiles/* and changing som hard links.  On
my coworker's laptop, I removed all of the profiles and started from
scratch.  I'd like to see these upgrades go a bit more smoothly.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 9
2. Set up multiple network profiles using redhat-config-network (we
have 3 or 4 each)
3. Upgrade to Fedora Core 1
4. Try to boot while specifying netprofile=<profilename> on the kernel
line
    

Actual Results:  Multiple network profiles loaded at the same time

Expected Results:  Settings from RedHat 9 should have been preserved

Additional info:

A sample of our network profile layout:

Home: Usually a wireless card setup with WEP, and either static or DHCP
Work: Wired, static IP
DHCP_Wired:  for travel
DHCP_Wireless: for coffeehouses  :-)
Comment 1 Harald Hoyer 2003-11-26 09:46:03 EST
the initscripts should start up, what is in
/etc/sysconfig/network-scripts/ifcfg-*
Did the profile switching leave some files from the other profile in
there??
Comment 2 Andy Grimm 2004-06-03 00:08:33 EDT
Nobody is really interested in this bug anymore.  I've stopped trying
to use the network profile switching, since it's a real mess to begin
with.  I'm going to just mark this closed.

Note You need to log in before you can comment on or make changes to this bug.