Bug 110921 - FTP Team functions don't work - ftp: URLs unsupported
FTP Team functions don't work - ftp: URLs unsupported
Status: CLOSED WONTFIX
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Handcock
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 10:57 EST by Jeremy Handcock
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 13:23:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2003-11-25 10:57:10 EST
Description of problem: The team FTP functions in eclipse don't
currently work because creating a new ftp: URL object always fails.  I
talked to Tom Tromey about this, and he said there isn't currently a
handler for ftp: URLs.

I kind of found this by accident.  We don't have a test case for this,
but we will in the future.

This seems to be a problem both with tree-ssa and gcc mainline.  I
don't know where the proper place to file this is - let me know if I
need to put it somewhere else.

Version-Release number of selected component (if applicable):
eclipse-2.1.1-3


How reproducible: Always


Steps to Reproduce:
1. Right click on project -> Target Site...
2. Select FTP and define a new FTP site
(or create a simple java program that creates a ftp: URL and compile
using gcj or gcj-ssa)
  
Actual results: The "URL" field in the FTP site creation dialog is
never valid ("Finish" button is never enabled) because the ftp: URL
object isn't properly instantiated.

Expected results: FTP site definition should proceed.
Comment 1 Tom Tromey 2003-12-01 16:54:12 EST
FYI, we can fix this by packaging GNU inetlib
(see inetlib module of Classpath repository)
and setting things up to use it by default.
Comment 2 Jeremy Handcock 2003-12-17 13:07:14 EST
I'm working on putting together a fix for this.
Comment 3 Ben Konrath 2004-11-29 13:23:16 EST
RHDS 2.0 (Eclipse 3.0) is no longer uses gcj, closing bug.

Note You need to log in before you can comment on or make changes to this bug.