Bug 110934 - OpenOffice Writer locks up when pasting image
OpenOffice Writer locks up when pasting image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 12:35 EST by Adrian Drzewiecki
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.2-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 05:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this problem (631 bytes, patch)
2004-11-05 19:35 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Adrian Drzewiecki 2003-11-25 12:35:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
When copying an image from Epiphany, and then pasting it into Writer, Writer becomes unresponsive. The program no longer updates its window, and I cannot close it. It has to be killed manually.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.'Edit --> copy' image in Epiphany
2.'Edit --> paste' in OO Writer
3.
    

Actual Results:  OO Writer is unresponsitve.

Expected Results:  Image pasted & displayed in document.

Additional info:

Oddly enough, this operation works just fine with the same version of OOo under SuSE 8.2.
Comment 1 Dan Williams 2003-12-04 10:51:36 EST
Can you post a URL that includes a picture with this problem?  I
cannot reproduce with relatively small images (ie PNG images under 100k).
Comment 2 Tracey C 2004-01-26 14:04:29 EST
Have you queried the OpenOffice bug list? You can do so here:
http://qa.openoffice.org/issue_handling/project_issues.html
What version of OO are you using?

After a few searches of the OO bug database on my own, I didn't see
anything offhand that directly relates to this problem. I did learn
that Epiphany in this case is a browser (there are other software
packages released under the name "Epiphany" elsewhere in the business
world). 

Do you happen to know if the image itself is pasted to the file or a
link to the image? I tried this at work (where I don't have Linux or
Epiphay, unfortunately, will try again from home). When I highlight an
image in Mozilla Firebird, Edit-Copy, go to a Writer doc and
Edit-Paste, it pastes a *link* to the image I copied.

Try this:
Within Epiphany, save the image to disk. Try copying the image from
disk and pasting in the Writer document. Does this also cause it to
freeze?

If pasting the image from disk does *not* cause OO to freeze, I'd be
tempted to say your problem is related to this bug in OO:
http://www.openoffice.org/issues/show_bug.cgi?id=9861

A relevant comment:
"OOo is very busy resolving the links to some graphics files."

Can you provide a link to the graphic you were trying to paste into
Writer?

Comment 3 Caolan McNamara 2004-11-05 18:58:51 EST
I can reproduce a crash with an image paste from epiphany and writer,
I'll look into it.
Comment 4 Caolan McNamara 2004-11-05 19:35:09 EST
Created attachment 106244 [details]
patch to fix this problem

Well that's an odd one, tracked it down to one file but problem went away when
I compiled with debugging symbols, and back when without. Looking at the
makefile.mk I see that under solaris intel this file gets compiled without
optimization to solve the same problem as I see. Patch attached to do that for
all platforms solves this bizarrity for us as well. 1.9.X series doesn't show
the problem.
Comment 5 Caolan McNamara 2004-11-05 19:37:34 EST
caolanm->dcbw: patch fixes problem for me anyway. Back to you for
consideration for inclusion.
Comment 6 Caolan McNamara 2004-11-11 05:55:44 EST
Cut and paste of google logo from epiphany to writer in 1.1.2-11
(FC2/FC3 updates) work for me now problem free.

Note You need to log in before you can comment on or make changes to this bug.