Bug 1109382 - rhc app-show <app_name> --gears reports haproxy for every gear
Summary: rhc app-show <app_name> --gears reports haproxy for every gear
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface
Version: 2.1.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Keywords: Upstream
Depends On: 1091071
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-13 18:54 UTC by Timothy Williams
Modified: 2014-08-26 13:52 UTC (History)
8 users (show)

(edit)
Previously, the 'rhc app-show <app_name> --gears' command reported HAProxy cartridges on every gear if the application was scalable. This reporting was not accurate, as each gear in the list should report only the cartridges actually on the gear. This bug fix updates the client tools, and HAProxy cartridges on gears are now accurately reported.
Clone Of:
(edit)
Last Closed: 2014-08-26 13:52:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1095 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.1.5 bug fix and enhancement update 2014-08-26 17:51:34 UTC

Description Timothy Williams 2014-06-13 18:54:16 UTC
Description of problem:
Currently, `rhc app-show <app_name> --gears` reports haproxy on every gear if the application is scalable. Each gear in the list should report only the cartridges on the gear.

Version-Release number of selected component (if applicable):
OSE 2.1.1
rhc 1.23.7.1

How reproducible:
Always

Steps to Reproduce:
1. Create a scalable application
2. Scale the application up at least one gear, assuming ALLOW_MULTIPLE_HAPROXY_ON_NODE is disabled
3. Run `rhc app-show <app_name> --gears`

Actual results:
# rhc app-show lbtest --gears
ID                     State   Cartridges           Size  SSH URL
---------------------- ------- -------------------- ----- -------------------------------------------------------------
539b2389fecb2d1b4600001b started haproxy-1.4 ruby-1.9 small 539b2389fecb2d1b4600001b@lbtest-admin.voyager.com
539b23bcfecb2d1b4600003a started haproxy-1.4 ruby-1.9 small 539b23bcfecb2d1b4600003a@539b23bcfecb2d1b4600003a-admin.voyager.com
539b25c4fecb2d1b46000051 started haproxy-1.4 ruby-1.9 small 539b25c4fecb2d1b46000051@539b25c4fecb2d1b46000051-admin.voyager.com
539b25c4fecb2d1b46000052 started haproxy-1.4 ruby-1.9 small 539b25c4fecb2d1b46000052@539b25c4fecb2d1b46000052-admin.voyager.com

Expected results:
# rhc app-show lbtest --gears
ID                     State   Cartridges           Size  SSH URL
---------------------- ------- -------------------- ----- -------------------------------------------------------------
539b2389fecb2d1b4600001b started haproxy-1.4 ruby-1.9 small 539b2389fecb2d1b4600001b@lbtest-admin.voyager.com
539b23bcfecb2d1b4600003a started ruby-1.9 small 539b23bcfecb2d1b4600003a@539b23bcfecb2d1b4600003a-admin.voyager.com
539b25c4fecb2d1b46000051 started ruby-1.9 small 539b25c4fecb2d1b46000051@539b25c4fecb2d1b46000051-admin.voyager.com
539b25c4fecb2d1b46000052 started ruby-1.9 small 539b25c4fecb2d1b46000052@539b25c4fecb2d1b46000052-admin.voyager.com

Additional info:

Comment 2 Luke Meyer 2014-06-13 21:38:10 UTC
Yes... yes, it does. The broker API doesn't really present the information in a format that you can use to determine which gear has what. This has been reported upstream.

Comment 4 Luke Meyer 2014-08-04 12:46:35 UTC
Small note: rhc modified upstream to correct this - users of the gem (which should be most/all) will have the fix before we officially ship the changes in rhc-on-RHEL channels.

Comment 7 Yanping Zhang 2014-08-11 05:06:18 UTC
Verified on rhc-1.28.5.1-1.el6op.noarch.

Steps to verify:
ALLOW_MULTIPLE_HAPROXY_ON_NODE is set false by default.
1.Create an scalable app, and check gear info.
# rhc app create php54 php-5.4 -s mysql
2.Scale up the app to contain at least 2 web gears.
# rhc cartridge scale php-5.4 -a php54 --min 3
3.Check each gear info.
# rhc app show php54 --gears

Actual results:
Will show right cartridge on each gear:
1.# rhc app show php54 --gears
ID                       State   Cartridges          Size  SSH URL
------------------------ ------- ------------------- ----- -------------------------------------------------------------------------
53e8463a16ae3171a000000a started mysql-5.5           small 53e8463a16ae3171a000000a@53e8463a16ae3171a000000a-domx.ose21z.example.com
53e8463a16ae3171a0000009 started php-5.4 haproxy-1.4 small 53e8463a16ae3171a0000009@php54-domx.ose21z.example.com

3.# rhc app show php54 --gears
ID                       State   Cartridges          Size  SSH URL
------------------------ ------- ------------------- ----- -------------------------------------------------------------------------
53e8463a16ae3171a000000a started mysql-5.5           small 53e8463a16ae3171a000000a@53e8463a16ae3171a000000a-domx.ose21z.example.com
53e8463a16ae3171a0000009 started php-5.4 haproxy-1.4 small 53e8463a16ae3171a0000009@php54-domx.ose21z.example.com
53e8470e16ae3171a000003b started php-5.4             small 53e8470e16ae3171a000003b@53e8470e16ae3171a000003b-domx.ose21z.example.com
53e8470e16ae3171a000003c started php-5.4             small 53e8470e16ae3171a000003c@53e8470e16ae3171a000003c-domx.ose21z.example.com

Comment 9 errata-xmlrpc 2014-08-26 13:52:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1095.html


Note You need to log in before you can comment on or make changes to this bug.