This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 110956 - wrong default permissions on /usr/share/fonts/default
wrong default permissions on /usr/share/fonts/default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
1
All Linux
high Severity medium
: ---
: ---
Assigned To: David Zeuthen
Mike McLean
:
: 90187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 16:41 EST by David K. Levine
Modified: 2013-03-05 22:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 16:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David K. Levine 2003-11-25 16:41:55 EST
Description of problem: the default installation does not set
executable permission on the subdirectory /usr/share/fonts/default and
practically nothing involving ghostscript works as a result. This is
easily fixed, but hard to identify. Please post a note or something so
that people know to fix it and don't spend hours tracking down why
printing, gs, etc. don't work.
Comment 1 Tim Waugh 2003-11-27 13:00:25 EST
Perhaps fontconfig should own /usr/share/fonts and
/usr/share/fonts/default?  Neither is owned at the moment.
Comment 2 Miloslav Trmac 2004-02-10 16:28:55 EST
*** Bug 90187 has been marked as a duplicate of this bug. ***
Comment 3 Ngo Than 2004-09-03 08:02:58 EDT
Owen, urw-fonts now owns this /usr/share/fonts/default
Comment 4 Matthias Clasen 2005-10-21 16:00:26 EDT
And fontconfig owns /usr/share/fonts, so this bug can probably be closed

Note You need to log in before you can comment on or make changes to this bug.