Bug 1109601 - dkms remove --no-initrd should only call /sbin/weak-modules with parameter --no-initramfs
Summary: dkms remove --no-initrd should only call /sbin/weak-modules with parameter --...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dkms
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-15 20:19 UTC by Rudd-O DragonFear
Modified: 2014-09-02 06:43 UTC (History)
5 users (show)

Fixed In Version: dkms-2.2.0.3-25.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 16:00:23 UTC


Attachments (Terms of Use)
Add --no-initramfs to weak-modules command (978 bytes, patch)
2014-06-16 08:25 UTC, Simone Caronni
no flags Details | Diff
Add --no-initramfs to weak-modules command (1.29 KB, patch)
2014-06-17 15:13 UTC, Simone Caronni
no flags Details | Diff

Description Rudd-O DragonFear 2014-06-15 20:19:32 UTC
Description of problem:

dkms remove --no-initrd calls /sbin/weak-modules without parameter --no-initramfs

This causes the regeneration of the initramfs.  This caused my system to be unbootable during the period between the old and the new DKMS modules package to be installed.

dkms-2.2.0.3-20.fc20

Comment 1 Simone Caronni 2014-06-16 08:25:46 UTC
Created attachment 909064 [details]
Add --no-initramfs to weak-modules command

Comment 2 Simone Caronni 2014-06-16 08:36:26 UTC
Could you explain a bit better what is the problem you're facing? I'm not sure I understood. A "period" between the old and the new DKMS module package is usually the same RPM transaction, so why it should be unbootable?

thanks,
--Simone

Comment 3 Rudd-O DragonFear 2014-06-17 05:55:14 UTC
The patch you posted is not correct.  It should execute the child process with the --no-initramfs parameter, ONLY when the dkms command has been invoked with the --no-initrd option.

That period of time we are discussing, is up to ten minutes between the execution of the dkms initrd reconstruction for one RPM install (spl-dkms) and the execution of another dkms initrd reconstruction for the next RPM install (zfs-dkms).  That is a ten minute window during which, if the system is rebooted accidentally, it has an invalid and unbootable initramfs.

I would know, cos it happened to me.

But ultimately the problem is a matter of principle -- if I invoke dkms with --no-initrd, I EXPECT it to not destroy my existing initrds as PROMISED by the --help option... and I also EXPECT it not to waste time (quite lengthy, within say a fully virtualized VM) rebuilding the initrd that I did NOT want to have rebuilt.

Comment 4 Simone Caronni 2014-06-17 15:13:15 UTC
Created attachment 909633 [details]
Add --no-initramfs to weak-modules command

Update for conditional

Comment 5 Simone Caronni 2014-06-17 15:19:21 UTC
Ok, understood. What about this patch?

I need to adjust it for EPEL 5, as RHEL 5's weak-modules has --no-initrd as parameter.

Ugly, but hey, dkms and all of its "if" are not pretty either. If you have a better approach please let me know.

Comment 6 Rudd-O DragonFear 2014-07-01 03:28:56 UTC
That looks perfect.  Push it.

Comment 7 Fedora Update System 2014-07-23 16:47:35 UTC
dkms-2.2.0.3-25.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-25.el6

Comment 8 Fedora Update System 2014-07-23 16:48:00 UTC
dkms-2.2.0.3-25.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-25.el5

Comment 9 Fedora Update System 2014-07-23 16:48:32 UTC
dkms-2.2.0.3-25.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-25.fc20

Comment 10 Fedora Update System 2014-07-23 17:03:14 UTC
dkms-2.2.0.3-25.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-25.fc19

Comment 11 Fedora Update System 2014-07-23 22:41:04 UTC
Package dkms-2.2.0.3-25.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing dkms-2.2.0.3-25.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2008/dkms-2.2.0.3-25.el6
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2014-07-26 16:00:23 UTC
dkms-2.2.0.3-25.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-09-02 03:53:51 UTC
dkms-2.2.0.3-25.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-09-02 03:56:08 UTC
dkms-2.2.0.3-25.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2014-09-02 06:43:00 UTC
dkms-2.2.0.3-25.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.